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Preface

Thank you for purchasing the Techno Shot Series monitor (hereafter referred to as “TS Series”).
Thoroughly read and understand the contents of this manual to ensure correct usage of the TS Series unit.
The following manuals relate to the TS Series unit.  Reference these manuals as required.

For more information on each type of controller (PLC, temperature control, etc.), refer to the manufacturer’s 
instruction manual for the corresponding controller.

Manual Name Description Reference 
No.

TS Series Training Manual (this manual) This manual provides detailed explanations of the 
screen creation process with examples using V-SFT 
version 5.

1203NE

TS Series Connection Manual This manual provides detailed explanations of the 
connections between the TS Series unit and each type 
of controller as well as communication settings.

2203NE

TS Series Hardware Specifications This manual explains the hardware specifications and 
operating methods of the TS Series unit.

2022NE

V8 Series Reference Manual This manual explains the functions and operating 
methods of the V8 Series.

1055NE

V8 Series Reference: Additional 
Functions

This manual explains the V8 Series functions and 
operating methods added to V-SFT version 5.1.0.0 and 
later.

1060NE

V Series Macro Reference This reference provides an overview of the macros 
available in V-SFT version 5 as well as detailed 
explanations of macro editor operations and macro 
commands.

1056NE

V8 Series Operation Manual This manual provides detailed explanations of 
information related to operating V-SFT version 5, such 
as software composition, editing procedures, and 
limitations.

1058NE

Notes:

1. No part of this manual may be reproduced without prior permission.

2. The contents of this manual may change without prior notice.

3. Windows and Excel are registered trademarks of Microsoft Corporation in the United States and other 
countries.

4. All other company names or product names are trademarks or registered trademarks of their 
respective holders.

5. While the utmost care has been taken in the production of this manual, please contact your local 
distributor regarding any doubts on the accuracy of explanations.



Notes on Safety

In this manual, you will find various notes categorized under the following levels with the signal words “DANGER,” 
and “CAUTION.”

Note that there is a possibility that items listed with  may have serious ramifications.

DANGER Indicates an imminently hazardous situation which, if not avoided, will result in death or 
serious injury.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, may result in minor or 
moderate injury and could cause property damage.

• Never use the input and output signals of the TS Series unit for operations that may threaten human life, 
cause damage to the system, or as emergency switches.  Please design the system so that it can withstand 
touch switch malfunctions.  Touch switch malfunctions may result in machine accidents or damage.

• Turn off the power supply when you set up the unit, connect new cables, or perform maintenance or 
inspections.  Failure to do so could cause electric shock or damage to the unit.

• Never touch any terminals while the power is on.  Otherwise, electric shock may occur.
• The liquid crystal in the LCD panel is a hazardous substance.  If the LCD panel is damaged, avoid ingesting 

any leaking liquid crystal.  If any liquid crystal spills onto your skin or clothing, use soap to wash it off 
thoroughly.

• Never disassemble, recharge, deform by pressure, short-circuit, or reverse the polarity of lithium batteries, 
and never dispose of lithium batteries in fire.  Failure to follow these conditions may lead to explosion or 
ignition.

• Never use lithium batteries that are deformed, leaking, or exhibit any other abnormalities.  Failure to follow 
these conditions may lead to explosion or ignition.

CAUTION

DANGER



• Check the appearance of the TS Series unit after unpacking.  Do not use the unit if any damage or 
deformation is found.  Using the unit in such a state may lead to fire, damage, or malfunction.

• Please consult your local distributor before using this product in facilities or systems related to nuclear 
energy, aerospace, medical, traffic equipment, or mobile installations.

• Operate (and store) the TS Series unit under the environmental conditions indicated in the general 
specifications of this manual and related manuals.  Failure to do so could cause fire, malfunction, physical 
damage or deterioration.

• Understand the following environmental limits for use and storage of TS Series units.  Failure to follow these 
conditions may result in fire or damage to the unit.

- Avoid locations where there is a possibility that water, corrosive gas, flammable gas, solvents, grinding 
fluids, or cutting oil may come into contact with the unit.

- Avoid high temperature, high humidity, and outside weather conditions, such as wind, rain, or direct 
sunlight.

- Avoid locations where excessive dust, salt, or metallic particles are present.
- Avoid installing the unit in a location where vibrations or physical shocks may be transmitted.

• Equipment must be correctly mounted so that the main terminal of the TS Series unit cannot be touched 
inadvertently.  Failure to do so may result in electric shock or accidents.

• Periodically check that the terminal screws on the power supply terminal block and mounting nuts are firmly 
tightened.  Using the unit with loose screws may result in fire or malfunction.

• Tighten the terminal screws on the TS Series power supply terminal block to an equal torque of 0.5 to 
0.6 N•m (5 to 6 kgf•cm).  Failure to tighten these screws properly may result in fire, malfunction, or damage 
to the system.

• Tighten the mounting nuts on the TS Series unit to equal torque within the specified range.  Note that 
excessive tightening may distort the panel surface.  Failure to tighten these nuts properly may cause the TS 
Series unit to fall, malfunction, or short-circuit.

• The TS Series features a glass screen.  Do not drop or impart physical shocks to the unit.  Such handling will 
damage the unit.

• Connect the cables correctly to the terminals of the TS Series unit in accordance with the specified voltage 
and wattage.  Failure to supply the correct voltage or wattage, or improper cable connection may cause fire, 
malfunction, or damage to the unit.

• Always ground the TS Series unit.  Ground the FG terminal of the TS Series unit with an independent D 
class grounding (ground resistance of 100 Ω or less).  Failure to do so may result in electric shock or fire.

• Prevent any conductive particles from entering into the TS Series unit.  Failure to do so may lead to fire, 
damage, or malfunction.

• Do not attempt to repair the TS Series unit at your site.  Contact Hakko Electronics Co., Ltd. or the 
designated contractor for repairs.

• Do not attempt to repair, disassemble, or modify the TS Series unit.  Hakko Electronics Co., Ltd. is not 
responsible for any damages resulting from repairs, disassembly, or modification of TS Series units 
performed by unauthorized personnel.

• Do not use sharp-pointed tools to press touch switches.  Doing so may damage the screen.
• Only personnel who possess the required knowledge and technical skills are authorized to set up the unit, 

connect the cables, and perform maintenance and inspections.
• Lithium batteries contain combustible material such as lithium and organic solvents.  Mishandling may cause 

heat, explosion, or ignition resulting in fire or injury.  Read the related manuals carefully and handle lithium 
batteries correctly as instructed.

• Do not press two or more positions on the screen at the same time.  If two or more positions are pressed at 
the same time, the switch located between the pressed positions will be activated.

• Take sufficient safety precautions during operations such as changing settings during running, forced output, 
start, and stop.  Operating errors may cause unexpected machine motions, resulting in machine accidents or 
damage.

• In facilities where TS Series unit failure could lead to accidents that threaten human life or result in other 
serious damage, make sure that such facilities are equipped with adequate safeguards.

• TS Series units must be disposed of as industrial waste.
• Before touching the TS Series unit, discharge any static electricity from your body by touching grounded 

metal.  Excessive static electricity may cause malfunction or damage to the unit.

CAUTION



[General Notes]
• Never bundle control cables and communication cables with high-voltage and large-current carrying cables 

such as power supply cables.  Keep these cables at least 200 mm away from high-voltage and large-current 
carrying cables.  Otherwise, malfunction may occur due to noise.

• When using the TS Series unit in an environment where a source of high-frequency noise is present, it is 
recommended that the FG shielded cable (communication cable) be grounded at both ends.  However, the 
cable may be grounded only at one end if necessary due to unstable communication conditions or for other 
reasons.

• Plug connectors and sockets of the TS Series unit in the correct orientation.  Otherwise, malfunction or 
damage may occur.

• Do not use thinners for cleaning because it may discolor the surface of the TS Series unit.  Use a commercially 
available alcohol-based cleaner instead.

• If a “data receive error” occurs when the TS Series unit and the counterpart unit (PLC, temperature controller, 
etc.) are started at the same time, read the instruction manual for the counterpart unit and handle the error 
accordingly.

• Avoid discharging static electricity on the mounting panel of the TS Series unit.  Static charge can cause 
malfunctions due to noise.

• Avoid prolonged display of any fixed pattern.  An afterimage may remain due to the characteristics of the liquid 
crystal display.  If a prolonged display of a fixed pattern is expected, use the backlight’s auto OFF function.

[Notes on the LCD Screen]
Note that the following conditions may occur under normal circumstances.

• The response time, brightness, and colors of the TS Series unit may be affected by the ambient temperature.
• Tiny spots (dark or luminescent) may appear on the display due to liquid crystal characteristics.
• Each unit varies slightly with respect to brightness and colors.
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11. Creating New Files
This chapter explains how to create new files and the initial screen displayed when the unit first 
starts up after turning on the power.

Screen Example.................................................................................................................. page 1-1
Screen Creation .................................................................................................................. page 1-2

1. Creating a New File .................................................................................................. page 1-2
2. Changing the Background Color .............................................................................. page 1-5
3. Drawing Graphics ..................................................................................................... page 1-7
4. Moving and Aligning Parts...................................................................................... page 1-13
5. Saving Files ............................................................................................................ page 1-16

Unit Operation................................................................................................................... page 1-17
Error Display............................................................................................................... page 1-17

The drawing tools are used to draw graphics, place text, and paste image files (JPEG, bitmap).

Contents

Screen Example
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1. Creating a New File

1. Start V-SFT-5.
2. Click [File] → [New] or click the [New File] icon.

3. Configure the following settings in the [Edit Model Selection] dialog box and click [OK].
Create the example screen in this manual with the following settings.

Edit Model : TS1100
 i Series : Selected

Color : 32K-Color

4. Configure the PLC type and TS connection port in the [PLC1 Connection Device Selection] 
dialog box and click [OK].
Create the example screen in this manual with the following settings.

Device connected : PLC
Maker : MITSUBISHI ELECTRIC
Series : QnH (Q) series link
Connect to : COM2

Screen Creation

or

New file icon
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15. Configure the communication parameters in the [Device Connection Setting] window.  For 
more information on settings in the [Device Connection Setting] window, refer to the “TS 
Series Connection Manual.”

6. Click the [Close] button to close the [Device Connection Setting] window.
The [Screen [0] Edit] window is displayed.

Close
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7. Click [System Setting] → [Font Setting].  The [Font Setting] dialog box is displayed.

8. Set the font using the [Setting] button.  Click the [OK] button to close the dialog box.
For more information on settings in the [Font Setting] dialog box, refer to the “V8 Series 
Reference Manual.”
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12. Changing the Background Color

This section explains how to change the background color.

1. Click [Screen Setting] → [Screen Setting].
The [Screen Setting] dialog box is displayed.

2. Click the [Back Color] button on the [Main] tab.  A drop-down list for color selection is 
displayed.
Select the desired background color.

3. The selected color is displayed on the icon and the background changes to this color.
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Click [Custom Color] to select a color that is not shown on the drop-down list.  The [Custom Color] 
dialog box is displayed.

Select the desired background color.
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13. Drawing Graphics

This section explains how to use the drawing tools to create text and draw graphics.

3.1 Draw Toolbar

The icons on the [Draw] toolbar are shown below.  Click the → symbol on the right of each icon to 
change the properties of each icon’s function.

Text

Rectangle

Bitmap image

Rectangle
Circle
Text/Multi Text
Dot
Paint
Graph Scale
Pattern/Library

Frame Type
Line Type
Arrow Type
Paint Color/
Background

Line 
Color/Frame 
Color
Character Color

Straight 
Line
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3.2 Creating a Rectangle

1. Click the [Rectangle] icon on the [Draw] toolbar.  The [Rectangle] icon becomes depressed 
and the mouse cursor changes to a cross-shaped cursor.

2.  Drag from the start point to the end point on screen using the mouse.  This draws a rectangle.
3. Set the color and frame type in the item dialog box.
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13.3 Creating Text
1. Click the [Text] icon on the [Draw] toolbar.

The [Text] icon becomes depressed.

2. Drag from the start point to the end point on screen using the mouse.
The specified area and a blinking cursor are displayed on screen.

3. Enter text.

4. Click a location on the screen other than the text.

Use [Multi Text] to enter more than two lines of text.

Drag

Blinking cursor

MONITOUCH
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5. Click the text to display its item dialog box.  Change the text color and text size properties.

Windows fonts on the computer can 
also be set in addition to the standard 
bitmap fonts.
Windows fonts on the computer can 
also be set.

Windows Fonts
The use of Windows fonts enables text size settings from 6 to 999 points and results in 
smoother display.

However, note that a common font should be used when editing on multiple computers 
because the types of Windows fonts can vary between computers.
A warning message is displayed if attempting to use a Windows font that is not present on 
the computer.  In this case, editing cannot be performed unless the missing font is 
substituted with another Windows font or the missing font is installed.



1. Creating New Files

1-11

S
creen C

reation

13.4 Pasting JPEG/Bitmap Files

This section explains how to load JPEG or bitmap files of company logos or machine image data 
onto the screen as pattern data.

1. Click [Tool] → [Paste Image File] → [Pattern].
The [Open Image File] dialog box is displayed.

2. Select the file to load and click [Open].  The loaded image is displayed.



1. Creating New Files

1-12

3. Click the [Place] button to place the image on the screen.

The loaded image is registered to [Registration Item] → [Pattern].  The image can be used on 
other screens by clicking the [Pattern] icon ( ) on the [Draw] toolbar and selecting 
the image for placement.

Loading the same image multiple times results in multiple registrations and increases the screen 
data size.  Delete any unnecessary patterns.

Delete
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14. Moving and Aligning Parts

This section explains how to move parts, change item size, and align multiple parts.

4.1 Moving Parts

1. Click on the part.  Handles are displayed around the part.
2. With the mouse cursor displaying a cross-shaped mark, drag the part to another position.

4.2 Enlarging and Reducing Part Size

1. Click on the part.  Handles are displayed around the part.
2. Place the mouse cursor over a handle.  The mouse cursor changes to a ↔ mark.
3. Drag the handle with the mouse cursor displayed as ↔.

Move

The part position can also be set using [Start X] and [Start Y] on the [Coordinates] tab in the item 
dialog box.

Start point

Enlarge horizontally

Enlarge horizontally and vertically
Enlarge vertically

Mouse cursor changes to 
↔ when nearing a handle

Handle
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4.3 Aligning Parts and Matching Size

This section explains how to align the positions and match the sizes of multiple parts at once.
1. Select the parts for alignment.  Handles are displayed around the parts.
2. Hold down the [Ctrl] key and click the reference part.  The handle color of this part changes 

and the part is specified as the reference part.

3. Use the [Layout] icons or the [Edit] menu → [Arrangement (Equal)] submenu or [Put All in 
Same Size] submenu to align the positions or match the sizes of parts.

Example: Left justification

The part size can also be set using [Width] and [Height] on the [Coordinates] tab in the item 
dialog box.

Width

Height

Reference part

Reference partClick

Placement Arrange/
equalize

Match 
size

Align parts to the left of 
the reference part.
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1Grid Settings/Center Line Display
Use [Center Line Display] and [Grid Display] to display center lines and grid lines of reference on 
screen to assist with item placement.  These lines are only displayed in the V-SFT software and 
not on the unit.

Display the center lines by clicking [View] → [Customize] → [Center Line Display].
Display grid line settings by clicking [View] → [Grid] → [Grid Display] and configure grid lines by 
clicking [View] → [Grid] → [Grid Setting].

Center line
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5. Saving Files

5.1 Saving as a New File

1. Click [File] → [Save As].  The [Select the image data to be saved.] dialog box is displayed.

2. Enter the desired filename and click [Save].

File creation is complete.  Screen data may now be transferred to the unit.
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1
Screen data is displayed when the TS Series unit and PLC are connected correctly.  Check that 
the unit operates properly.

1. Error Display

1.1 Communication Error - Timeout

Communication is not being performed correctly due to any of the following reasons.
• The model select for screen data in the [Device Connection Setting] window differs from the 

actual connected model.
• The communication parameters of the TS Series unit and the PLC do not match.
• The communication cable is not connected correctly or disconnected.

1.2 Screen No.  Error

Check the value of the screen number command specified in the read area (n + 2).

Unit Operation

MONITOUCH

TECHNOSHOT

Data Loading...

Screen No. Error
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The TS Series unit displays screens by looking at the memory value of the screen number 
command when communication starts.  The “Screen No. Error” message is displayed if this value 
is set to a screen number that does not exist.

For the screen data in this manual, the [Read Area] value is “D0000” so the screen number 
command memory is “D0002”.  For data where screen numbers 0 to 5 have been created:

D0002 = 0 to 5 → Display correctly
D0002 = 6 to 9999 → Screen No. Error

Read Area
The [Read Area] and [Write Area] settings can be accessed by clicking [System Setting] → 
[Device Connection Setting].
The read area is the memory address where the PLC issues display or operation commands to 
the TS Series unit.  Three words of consecutive memory addresses are secured for this 
purpose.

Write Area
This memory address is for outputting the screen status from the TS Series unit to the PLC.  
Three words of consecutive memory addresses are secured for this purpose.

Read Area Description Setting Example

n Subcommand D0

n + 1 Screen status command D1

n + 2 Screen number command D2

Write Area Description Setting Example

n Subcommand state D50

n + 1 Screen status D51

n + 2 Displayed screen number D52
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2. Creating Switches and Lamps
This chapter explains how to create screens that contain switches and lamps.

Screen Example.................................................................................................................. page 2-1
Screen Creation .................................................................................................................. page 2-2

1. Editing Screens ...................................................................................................... page 2-13
2. Procedure for Changing Parts ................................................................................ page 2-13

Confirming Unit Operation ................................................................................................ page 2-19
1. Memory Addresses................................................................................................. page 2-19
2. Unit Operation ........................................................................................................ page 2-19

Create the following example screen that uses switch output to turn lamps on and off and switches 
to another screen using a switch.

Contents

Screen Example
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1. Editing Screens

1.1 Creating a New Screen

3. Click the [Next Screen] icon to display the [Screen [1] Edit] window.

1.2 Changing the Background Color

Change the background color of the screen by clicking [Screen Setting] → [Screen Setting].
For more information, refer to “Changing the Background Color” on page 1-5.

Screen Creation
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1.3 Placing Switches

1. Click [Parts] → [Parts List].  The [Parts List] window is displayed.

2. Select [Switch], [Real], and [#1 [Square1]].

3. Select a switch and drag it onto the screen.  This places the switch on the screen.

Drag
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5. Configure each setting in the switch’s item dialog box.
• [Main] tab

Set the bit memory address for output and select a setting for [Function].

In addition to the [Parts List], the following four methods are available for placing parts.
1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1.  Parts icons

2.  [Parts] menu 3.  [Catalog] dialog box 4.  Wizard ([Parts] menu)

Item Details Setting Value

Output Memory Set the bit memory address to output when the switch is pressed. Selected
M100

Multi-output Select this checkbox to perform a single output action with 
respect to multiple memory addresses.

Deselected
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Output Action Set the write operation to perform with respect to the output 
memory address.

Momentary

Lamp Memory Change the display of the switch area.

Deselected:
Pressing the switch turns on the lamp in the switch.  Releasing 
your finger from the switch turns the lamp off.

Selected:
Set the memory address for the lamp display using [Memory 
Designation] and [Input Type].

-

Connect Output 
Memory and Lamp 
Memory

Select this checkbox to use the same memory address for output 
memory and lamp memory.

Selected

Function Set the function of the switch, or in order words, how the switch 
should work when it is pressed.  Functions that are frequently 
used include “Screen”, “Overlap Display”, and “Multi-Overlap 
Display”.*1

No Function

*1 For more information on functions, refer to the “V8 Series Reference Manual.”

Item Details Setting Value

Switch 
Operation

Output Processing

Set The specified bit memory address is set to 
“ON”.

Reset The specified bit memory address is reset 
to “OFF”.

Momentary
Momentary W

The specified bit memory address is set to 
“ON” while the switch is depressed.

Alternate The specified bit memory address is 
alternately set (ON) and reset (OFF) each 
time the switch is pressed.
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• Text
Set the text displayed on the switch.

• Changes to the settings on the [Interlock], [Macro], [Style], [Delay], [Detail], and [Display 
Setting] tabs are not covered in this section.

Item Details Setting Value

OFF, ON to P128
Pattern No.

Register the text to be displayed on the switch. M100

Color
Property
Enlarge
Point
Rotation + Direction
Windows Font

Set the text color, properties, and text size. -

If the switch displays 
different text in the ON and 
OFF states, register the 
text to display in each state 
on the [ON] and [OFF] 
tabs.
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1.4 Creating Multiple Copies of Switches

This section explains how to copy a switch multiple times.
1. Select a switch.  Handles are displayed around the switch.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon.  The [Multi Copy] dialog box is 
displayed.

3. Set the options as shown below and click [OK].  This copies the switch multiple times.

or
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4. Click [View] → [Customize] → [Memory Display].  Memory addresses are displayed at the 
lower left on each switch.

5. Change the switch text and output action to the following.

This completes the switch creation process.

[Main] tab
Output Action: Alternate

[Text] tab
OFF: M101

[Main] tab
Output Action: Set

[Text] tab
OFF: M102

[Main] tab
Output Memory: 
M102
Output Action: Reset

[Text] tab
OFF: M102
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1.5 Placing Lamps

1. Click [Parts] → [Parts List].  The [Parts List] window is displayed.
2. Select [Lamp], [Real], and [#0 [Circle1]].

3. Select a lamp and drag it onto the screen.  This places the lamp on the screen.

4. Configure each setting in the lamp’s item dialog box.
• [Main] tab

Set the memory address for the lamp.

Item Details Setting Value

Lamp Memory The display of the lamp area can be changed.
Set the memory address for the lamp display using [Memory 
Designation] and [Input Type].

M100

Function Set the lamp’s function.
Normally select [No Function].

No Function

Drag
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• [Text] tab
Set the text displayed on the lamp.

• Changes to the settings on the [Style], [Detail], and [Display Setting] tabs are not covered in 
this section.

Item Details Setting Value

OFF, ON to P128
Pattern No.

Register the text to be displayed on the lamp. M100

Color
Property
Enlarge
Point
Rotation + Direction
Windows Font

Set the text color, properties, and text size. -

If the lamp displays different text in 
the ON and OFF states, register the 
text to display in each state on the 
[ON] and [OFF] tabs.
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1.6 Creating Multiple Copies of Lamps

Create multiple copies of lamps using the same procedure for multiple copies of switches.

1. Select the lamp.  Handles are displayed around the lamp.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon.  The [Multi Copy] dialog box is 
displayed.

3. Set the options as shown below and click [OK].  This copies the lamp multiple times.

or



2. Creating Switches and Lamps

2-12

4. Change the text displayed on each lamp.

This completes the lamp creation process.

[Text] tab
M101

[Text] tab
M102
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2. Procedure for Changing Parts

Perform the following procedure to change the design or color of parts placed on the screen.

2.1 Changing Parts

1. Select the part for changing to display its item dialog box.

2. Click [Style] → [Change Part].  The [Change Part] window is displayed.
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3. Select the part using [Change Part Color] and [Part Type Change].

4. Select the part properties for changing and click [Select] to change the lamp on the screen.

Item Details

Maintain Size Deselected:
Change to the default size.

Selected:
Maintain the size prior to changing.

Pattern Change The pattern image of OFF, ON, and patterns up to P128 can be checked.

Change Part Color Change the color.

Part Type Change Change the part type.
Real/Sign/3D
Circle/Square/Plant/Icon etc.
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2.2 Changing the Color of Parts

1. Select the part for changing to display its item dialog box.

2. Select the pattern (OFF/ON/P3 or higher) whose color is to be changed on the [Style] tab and 
click [Customize].

3. Select an image and color in the [Change the image] window.
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Different color settings for OFF and ON can be configured by changing the color in the [Change 
the image] window.

Before change

After change

OFF ON
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2.3 Placing Text

This section explains how to place the screen title and other text elements.

♦ Creating Text
1. Click the [Text] icon on the [Draw] toolbar.  A cross-shaped cursor is displayed.

2. Click on the screen.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box.  Change the text color and text size properties.

Text

Text
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2.4 Creating a Switch for Changing to Another Screen

This section explains how to place a switch that changes between screen 0 and screen 1 when 
pressed.

1. Place a switch.
2. Set [Function] to “Screen” in the switch’s item dialog box and set [Screen No.] to the number of 

the destination screen.

3. Adjust the switch color and position.

This completes the screen creation process.  The next section covers confirming screen operation 
on the TS Series unit.

Switch
Function: Screen 1

Screen 0

Screen 1

Switch
Function: Screen 0
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1. Memory Addresses

The memory addresses used in this example are listed below.

2. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

2.1 Switching Screens

1. Screen 0 is displayed initially.
(Refer to the next page if a different screen or “Screen No. Error” is displayed.)

2. Press [Screen1] at the upper right of the screen.  The screen changes to display screen 1.

Confirming Unit Operation

Memory 
Address

Memory Contents

M100 Switch output memory (momentary), lamp memory
M101 Switch output memory (alternate), lamp memory
M102 Switch output memory (set/reset), lamp memory
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Changing Screens Using PLC Commands (External Commands)

The [Read Area] and [Write Area] settings, accessed by clicking [System Setting] → [Device 
Connection Setting], are used for this purpose.  “D0002” is used for the screen number 
command memory in this manual.

Setting “D0002” to the screen number will allow the display to change.  Note that the screen 
number of the currently displayed screen is stored using “D0052” in the [Write Area].

The screen number to display when the unit is powered on is also determined by “D0002”.
The “Screen No. Error” message is displayed if a screen number that does not exist is set.

For more information on the [Read Area] and [Write Area], refer to page 1-17.

PLC

Screen0

D0002 0

D0052 0

PLC

Screen1

D0002 1

D0052 1
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2.2 Switch Output and Lamp Display

♦ Momentary Switch
The output memory address is set to “ON” while the switch is depressed.

1. Press the M100 (momentary) switch.  The M100 lamp turns on.

2. Releasing your finger from the switch turns the M100 lamp off.
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♦ Alternate Switch
The specified bit memory address is alternately set (ON) and reset (OFF) each time the switch is 
pressed.

1. Press the M101 (alternate) switch.  The M101 lamp turns on.

2. The M101 lamp stays on even after releasing your finger from the switch.

3. Press the M101 (alternate) switch again.  The M101 lamp turns off.

The ON/OFF state of the lamp changes each time the switch is pressed.
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♦ Set/Reset Switch
The specified bit is set to “ON” or “OFF”.

1. Press the M102 (set) switch.  The M102 lamp turns on.

2. The M102 lamp stays on even after releasing your finger from the switch.

3. Press the M102 (reset) switch.  The M102 lamp turns off.
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Please use this page freely.
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3. Creating Overlaps
Windows can be temporarily overlaid on the displayed screen when necessary.  These types of 
windows are referred to as “overlaps”.
A maximum of four overlaps can be displayed at once on the screen.

Overlaps that are frequently used include normal overlaps, which can only be displayed on the 
screen on which they are created, and multi-overlaps registered to the overlap library that can be 
used across several screens.

• Normal Overlap

• Multi-overlap
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554

1653

10.23

9.89
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11.02

12.03

849

988
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Do you wish to save?
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Menu
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Screen Example.................................................................................................................. page 3-2
Screen Creation .................................................................................................................. page 3-3

1. Editing the Overlap Library ....................................................................................... page 3-3
2. Editing Screens ........................................................................................................ page 3-8

Confirming Unit Operation ................................................................................................ page 3-14
1. Unit Operation ........................................................................................................ page 3-14

Add a multi-overlap to screen 1, which was created with switches and lamps.

Contents

Screen Example
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1. Editing the Overlap Library

This section explains how to create overlaps.

1.1 Placing Overlaps

1. Click [Registration Item] → [Overlap Library].  The [Overlap Library] dialog box is displayed.

2. Select a registration number and click the [OK] button.  The [Overlap Library Edit] window is 
displayed.

3. Click [Parts] → [Overlap] → [Normal Overlap] to place an overlap.

Screen Creation

Almost all items including switches, lamps, and alarms can be placed on overlaps.
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4. Configure settings in the item dialog box.
• [Main] tab

• [Style] tab

• [Detail] tab
Settings on this tab do not require configuration.

• [Coordinates] tab
Set the placement position and size of the overlap.

Item Description Setting 
Value

System Button Select this checkbox to add a switch function (move/dismiss) to 
the upper left corner of the overlap area.
For more information on the operation of this switch, refer to 
“1.2 Overlap System Button Function” (page 3-15).

Selected

Item Description Setting 
Value

Color
Frame, Area

Set the area color. -

Change Part Change the part used for the overlap. -
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1.2 Placing Text

This section explains how to place text on the overlap.

1. Click the [Text] icon ( ).  A cross-shaped cursor is displayed.

2. Click on the overlap.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box.  Change the text color and text size properties.

The size of the overlap can also be changed by selecting the overlap and dragging the displayed 
handles.

Drag
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1.3 Placing Switches

This section explains how to create a switch for hiding the overlap.

1. Click [Parts]  [Parts List].  The [Parts List] window is displayed.
2. Select [Switch], [Real], and [#18 [Icon10]].

3. Select a switch and drag it onto the overlap.  This places the switch on the overlap.

Drag
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4. Set the [Function] option in the switch’s item dialog box.
Function: Standard, Overlap Display
Overlap ID: 0
Action: OFF

The completes the overlap editing process.

Match the overlap ID to the ID of the screen’s overlap 
icon.
(For more information on the overlap icon, refer to page 
3-12.)

Edit items on the overlap by clicking [Overlap Editing] → [No. 0] on the right-click menu.
This allows multiple items to be selected by dragging with the mouse.
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2. Editing Screens

This section explains how to register a multi-overlap icon and a switch for displaying a 
multi-overlap.

2.1 Placing the Switch

1. Display the [Screen [1] Edit] window.

2. Click [Parts]  [Parts List].  The [Parts List] window is displayed.

Switch

Multi-overlap
icon
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3. Select [Switch], [Real], and [#1 [Square1]].

4. Select the switch and drag it onto the screen.  This places the switch on the screen.

Drag

In addition to the [Parts List], the following four methods are available for placing parts.
1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1.  Parts icons

2.  [Parts] menu 3.  [Catalog] dialog box 4.  Wizard ([Parts] menu)
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5. Set the [Function] option in the switch’s item dialog box.
• [Main] tab

*1 The settings for normal overlap display are:
[Main] tab
Function: Overlap Display
Action: ON

Item Details Setting Value

Output Memory Set the bit memory address to output when the switch is pressed. Deselected

Lamp Memory Change the display of the switch area.

Deselected:
Pressing the switch turns on the lamp in the switch.  Releasing 
your finger from the switch turns the lamp off.

Selected:
Set the memory address for the lamp display using [Memory 
Designation] and [Input Type].

Deselected

Function Select the function of the switch, or in order words, how the 
switch should work when it is pressed.  Functions that are 
frequently used include “Screen”, “Overlap Display”, and 
“Multi-Overlap Display”.*1

Multi-Overlap 
Display

Overlap ID Set the overlap ID.
Setting value: 0 to 2

0

Overlap Library No. Set the overlap library number.
Setting value: 0 to 9999

0

Display Position Set the [X Coordinate] and [Y Coordinate] values for the display 
position of the overlap.
Specify with Mouse: Specify the coordinates by clicking with the 
mouse.*2

Selected
X120
Y125
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*2 Mouse specification method
Click the [Specify with Mouse] button.  A cross-shaped cursor and a rectangle the size of the overlap are 
displayed.

Click on a position where the rectangle does not protrude outside the screen.  The  mark that shows 

the display position of the multi-overlap moves to the clicked position.

• [Text] tab
Register the text displayed on the switch.

This completes the switch creation process.

OVLP Click
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2.2 Registering an Overlap Icon

1. Click [Parts] → [Overlap] → [Multi-Overlap].

2. Click on the screen to place the multi-overlap icon.

3. Configure settings in the item dialog box.
• [Main] tab

Item Details Setting Value

Overlap ID A maximum of three overlaps can be displayed at once.
Set the area of IDs 0 to 2 in which to display the overlap 
registered in the overlap library.
Setting value: 0 to 2

0

Designate
Internal, External

Internal
Display the overlap using the switch function.

External
Specify the overlap library number in a memory address and 
show or hide the overlap according to the bit in the read area 
or command memory.

Internal



3. Creating Overlaps

3-13

S
creen C

reation

3
• [Detail] tab

Settings on this tab do not require changing.

This completes the screen creation process.  The next section covers confirming screen operation 
on the TS Series unit.

Info Output Memory Stores the currently displayed overlap library number.
This memory address stores “-1” when the overlap display is 
hidden.

-

Overlap Library No. This option is valid when [Designate] is set to “External”.
This memory address specifies the overlap library number.

-

Coordinate 
Designation

This option is valid when [Designate] is set to “External”.
Select this checkbox to set the display position of the overlap (X 
and Y coordinates).

-

Item Details Setting Value
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1. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

1.1 Showing and Hiding Multi-overlaps

1. Display screen 1.

2. Press the [OVLP] switch.  The overlap is shown.

3. Press the [CLOSE] switch.  The overlap is hidden.

Confirming Unit Operation
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1.2 Overlap System Button Function

A system button function can be added to overlaps.
This function can perform the following two operations.

• Overlap movement
• Overlap dismissal

1. Press the [OVLP] switch to display the multi-overlap.

2. Press the upper left corner of the overlap.  The periphery of the overlap starts flashing.

Movement and dismissal of overlaps is only available when the [System Button] checkbox is 
selected in the overlap settings.

Periphery of the 
overlap flashes
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3. While the periphery of the overlap is flashing, press the position to move the overlap.
The overlap moves to the specified position.

4. Double-tap the upper left corner of the overlap to dismiss it.

Press the position to move the 
overlap with your finger
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4. Entry Screens
This chapter explains how to create a keypad entry screen.  As keypads are usually not 
permanently displayed on screens, here we will create a screen that displays a keypad only when 
entry is required.

• Normal: Keypad OFF

• Entry: Keypad displayed

Screen Example.................................................................................................................. page 4-2
Screen Creation .................................................................................................................. page 4-3

1. Editing Screens ........................................................................................................ page 4-3
2. Overlap Library ....................................................................................................... page 4-14

Confirming Unit Operation ................................................................................................ page 4-19
1. Memory Addresses................................................................................................. page 4-19
2. Unit Operation ........................................................................................................ page 4-19

Tap the numerical data 
display to display the keypad.

Press the [Enter] key to hide 
the keypad.

Contents
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In this section, create a screen for entering values into parts “D100” through “D115”.

Screen Example

PLC

D100
D101
D102
D103

33 Dec
0 Dec
 0 Dec
0 Dec

D100
D101
D102
D103

0 Dec
0 Dec
 0 Dec
0 Dec

PLC

Keypad display

Entry
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1. Editing Screens

Screen editing involves registration of numerical data and character displays targeted for writing as 
well as multi-overlaps.

1.1 Placing Numerical Data Displays and Registering Keypads

1. Click [Parts] → [Parts List].  The [Parts List] window is displayed.
2. Select [Entry], [Real #0 NUM.Display].

Screen Creation

Multi-overlap Character 
display

Numerical
data display
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3. Select a numerical data display part and drag it onto the screen.  This places the numerical 
data display on the screen.

4. Configure each setting in the numerical data display’s item dialog box.
• [Main] tab

Set the memory address for writing and select a setting for [Function].

Item Details Setting Value

Memory Set the memory address for writing. D100

Offset Value 
Designation 
Memory

Select this checkbox to specify an offset.
Not used in this section.  For more information, refer to the “V8 
Series Reference Manual.”

Deselected

Data Length Set the data length of the memory address for writing.
Setting value: 1-Word/2-Word

1-Word

Drag
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*1 Registration method
Setting [Overlap Library No.] to “1” and clicking the [Register] button displays the [Change Part] window.  
Select the design and color and then click the [Select] button.

A keypad is registered to the specified overlap library number.  For more information on the registered 
details, refer to page 4-14.
If the specified overlap library number is already registered, the following confirmation message is 
displayed.
Select [Yes] to overwrite the overlap library number or select [No] to register the keypad to another overlap 
library number.

Digits Set the number of digits used by the memory address for writing.
Setting value: 1 to 32

5

Decimal Point Select whether to include a decimal point.
Setting value:

0: No decimal point
1 to 10: Insert decimal point (at corresponding 1st to 10th 

decimal place)

0

Display Type Set the format of numbers to be displayed on the screen. DEC
(with sign +-)

Input Type Set the format for reading values from memory. DEC

Zero Suppress Select this checkbox to enable zero suppression. Selected
Flush Right

Function Set the numerical data display function. Entry Target

Order INC Set the order in which the cursor moves when multiple entry 
targets are placed on the screen.

0

With Entry Key Function: Entry Target (enabled when selected)
Select this checkbox to add the entry key call function.

Selected

Overlap ID Set the overlap ID to be used for showing the entry keys.
Setting value: 0 to 2

0

Overlap Library No.
Register button*1

Set the overlap library number for registering the entry keys.  
Select the desired keypad by pressing the [Register] button and 
register the keypad to the overlap library.
If the keypad is already registered to the overlap library, simply 
specify the overlap library number.
Setting value: 0 to 9999

1

Display Position
X Coordinate
Y Coordinate
Specify with 
Mouse button*2

Set the [X Coordinate] and [Y Coordinate] values for the display 
position of the overlap.
[Specify with Mouse] button: Specify the coordinates by clicking 
with the mouse.

Selected
X Coordinate: 

240
Y Coordinate: 

145

Item Details Setting Value

12 00012
Space

Selected (Flush Right) Deselected
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*2 Mouse specification method
Click the [Specify with Mouse] button.  A cross-shaped cursor and a rectangle the size of the overlap are 
displayed.

Click on a position where the rectangle does not protrude outside the screen.  The  mark that shows 
the display position of the multi-overlap moves to the clicked position.

• [Style] tab
Set text properties of the entry target.
Use the [Change Part] button to change parts.

• Operation/Alarm
Set the alarm options.

• Changes to the settings on the [Detail], [Comment], and [Display Setting] tabs are not covered 
in this section.

Item Details Setting Value

Alarm Select this checkbox to use the alarm function. Selected

Min. Set the minimum and maximum entry values.
Values outside this range cannot be entered.

−5000
Red

Max. 5000
Blue

Word Operation Not used in this section.
For more information, refer to Chapter 5 in the “V8 Series 
Reference Manual.”

Deselected

Scaling

OVLP

Click
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1.2 Creating Multiple Copies of Numerical Data Displays

1. Select the numerical data display on the screen.  Handles are shown around the numerical 
data display.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon.  The [Multi Copy] dialog box is 
displayed.

3. Set the options as shown below and click [OK].  This copies the numerical data display.

or

Y

Copy direction

X
(100)

(5)
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4. Select [View] → [Customize] → [Memory Display].

Memory addresses are displayed at the lower left on each numerical data display.  The 
memory addresses are set from “D100” to “D109”.

5. Change the settings of each numerical data display.  In this section, change the settings to the 
following.

[Main] tab
Decimal Point: 1

[Main] tab
Digits: 4
Display Type: HEX
Zero Suppress: Deselected

Display Position
X Coordinate: 400
Y Coordinate: 145

[Operation/Alarm] tab
Alarm: Deselected
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This completes the numerical data display and entry key registration process.

Configuring Multiple Items at Once in the Item Dialog
The settings of multiple items can be configured at once by selecting multiple instances of the 
same item.
1. Select all of the numerical data display items for configuration.

The [Num. Display (Multiple Selection)] item dialog box is displayed.

2. Change [Decimal Point] to “1”.  All the selected numerical data displays are updated with 
this change.

Note that blank settings denote 
setting values that differ for each 
item.
Take care when changing these 
settings.
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1.3 Placing Character Displays and Registering Character Keys

1. Click [Parts] → [Parts List].  The [Parts List] window is displayed.
2. Select [Entry], [Real #1 CHRA.Display].

3. Select a character display part and drag it onto the screen.  This places the character display 
on the screen.

Drag
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4. Configure each setting in the character display’s item dialog box.
• [Main] tab

Set the memory address for writing and select a setting for [Function].

Item Details Setting Value

Memory Set the memory address for writing. D110

Offset Value 
Designation 
Memory

Select this checkbox to specify an offset.
Not used in this section.  For more information, refer to the “V8 
Series Reference Manual.”

Deselected

No. of Bytes Set the number of bytes for the character array.
Setting value: 1 to 127

12

Character Position Select either flush-left or flush-right for the character display. Flush Left

Text Process Set the order of the 1st byte and 2nd byte in 1 word.

[LSB → MSB]

[MSB → LSB]

LSB→MSB

Function Set the character display function. Entry Target

Order INC Set the order in which the cursor moves when multiple entry 
targets are placed on the screen.

0

With Entry Key Function: Entry Target (enabled when selected)
Select this checkbox to add the entry key call function.

Selected

Overlap ID Set the overlap ID to be used for showing the character entry 
keys.
Setting value: 0 to 2

0

Overlap Library No.
Register button*1

Set the overlap library number for registering the character entry 
keys.  Select the desired keyboard by pressing the [Register] 
button and register the keyboard to the overlap library.
If the keyboard is already registered to the overlap library, simply 
specify the overlap library number.
Setting value: 0 to 9999

2

Flush Left →    ABC
Flush Right →        ABC

MSB     LSB
2nd byte     1st byte

15                               0

LSB      MSB
1st byte     2nd byte

15                               0
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*1 Registration method
Setting [Overlap Library No.] to “2” and clicking the [Register] button displays the [Change Part] window.  
Select [Real #4 [Character TS]] and click the [Select] button.

The character keys are registered to the specified overlap library number.  For more information on the 
registered details, refer to page 4-14.
If the specified overlap library number is already registered, the following confirmation message is 
displayed.
Select [Yes] to overwrite the overlap library number or select [No] to register the character keys to another 
overlap library number.

*2 Mouse specification methodRefer to 
page 4-6.

This completes the character display and entry key registration process.

 Display Position
X Coordinate
Y Coordinate
Specify with 
Mouse button*2

Set the [X Coordinate] and [Y Coordinate] values for the display 
position of the overlap.
[Specify with Mouse] button: Specify the coordinates by clicking 
with the mouse.

Selected
X Coordinate: 

100
Y Coordinate: 

182

Item Details Setting Value
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1.4 Placing Text

This section explains how to place the screen title and text that indicates memory address 
numbers.

1. Click the [Text] icon ( ).  A cross-shaped cursor is displayed.

2. Click on the screen.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box.  Change the text color and text size properties.

The completes the screen editing process.

Text

1.  [Text] icon
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2. Overlap Library

The following items are registered to the overlap library contain the entry keys registered using the 
[Register] button.  These can be used without changing any settings.
If size adjustment or color changes are required, change these settings in the [Overlap Library 
Edit] window.

• Overlap library number 1 (keypad)

• Overlap library number 2 (character keys)

2.1 Editing the Overlap Library

1. Click [Registration Item] → [Overlap Library].  The [Overlap Library] dialog box is displayed.

Entry icon Max. value display

Min. value display

Entry display

Keypad

Overlap

Entry icon

Overlap

Entry display

Character entry keys
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2. Specify number “1” for the overlap library to which the entry key is registered.
The [Overlap Library Edit] dialog box is displayed.

♦ Overlap Settings
1. Click the overlap to display its item dialog box.  Properties such as area color and size can be 

changed in this dialog box.
• [Main] tab

• [Style] tab

Item Description Setting 
Value

System Button Select this checkbox to add a switch function (move/dismiss) to 
the upper left corner of the overlap area.
For more information on the operation of this switch, refer to 
page 3-14 in “Showing and Hiding Multi-overlaps.”

Deselected

Item Description Setting 
Value

Color
Area

Set the area color. -

Change Part Change the part used for the overlap. -
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• [Detail] tab
Settings on this tab do not require changing.

• [Coordinates] tab
Set the placement position and size of the overlap.  Settings on this tab do not require 
changing.

♦ Settings of Items Placed on the Overlap
Edit items on the overlap by clicking [Overlap Editing] → [No. 0] on the right-click menu.

2.2 Entry Icon

An entry icon for configuring keypad settings is displayed at the upper left of the keypad placed on 
the screen.  If this entry icon is not displayed or settings are incorrect, the keypad will not function 
correctly.
In this section, use the keypad without changing any settings.
For more information on the entry icon, refer to Chapter 7 in the “V8 Series Reference Manual.”

The size of the overlap can also be changed by selecting the overlap and dragging the displayed 
handles.

Drag

Entry icon
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2.3 Entry Display Part/Max. Value Display Part/Min. Value Display Part

The entry display part function temporarily displays values entered using the entry keys.
The max. value display part and min. value display part functions display the range of values that 
can be entered using the entry keys.
The maximum and minimum values set for [Alarm] when [Function] is set to “Entry Target” are 
displayed automatically.
This section only explains the essential settings for each function.

♦ Overlap Library No. 1
1. Click on the overlap.  The numerical data display’s item dialog box is displayed.
2. Configure the numerical data display settings.

• [Main] tab

• [Style] tab
Set text properties of the entry target.
Use the [Change Part] button to change parts.

• [Detail] tab

• [Coordinates] tab
Adjust the placement position.

Item Description Setting Value

Digits For entry display parts on the TS Series unit, the system 
automatically refers to the properties set for the entry 
target.  Configure these settings for the purpose of 
layout.  Set the part by referring to the greatest value or 
the longest display among the entry targets.

5

Decimal Point 1

Display Type DEC
(with sign +-)

Zero Suppress Selected
Flush Right

Function Set the function to use. Entry Display 
Part

Max. Value 
Display Part
Min. Value 

Display Part

Item Description Setting 
Value

ID Set the ID.  Always set the same ID as that shown on the entry icon. 0
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♦ Overlap Library No. 2
1. Click on the overlap.  The character display’s item dialog box is displayed.
2. Configure the character display settings.

• [Main] tab

• [Style] tab
Set text properties of the entry target.
Use the [Change Part] button to change parts.

• [Detail] tab

• [Coordinates] tab
Adjust the placement position.

The completes the overlap library editing process.  The next section covers screen operation after 
transferring screen data to the TS Series unit.

Item Description Setting 
Value

No. of Bytes For entry display parts on the TS Series unit, the system 
automatically refers to the properties set for the entry target.  
Configure these settings for the purpose of layout.  Set the part 
by referring to the greatest value or the longest display among 
the entry targets.

12

Character Position Select either flush-left or flush-right for the character display. Flush 
Right

Function Set the function to use. Entry 
Display 

Part

Item Description Setting 
Value

ID Set the ID.  Always set the same ID as that shown on the entry 
icon.

0

Flush Left →    ABC
Flush Right →        ABC
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1. Memory Addresses

The memory addresses used in this example are listed below.

2. Unit Operation

2.1 Entering Values

1. Press the numerical data display for “D100”.  This displays the keypad overlap and highlights 
the value for “D100”.

Confirming Unit Operation

Memory 
Address Memory Contents

D100 to 109 Numerical data display (Entry Target)
D110 to 115 Character display (Entry Target)
$u16330 * Entry mode (Command Memory)
$u16340 * Entry mode (Info Output Memory)/Multi-overlap (Info Output Memory)

* Change to a different memory address to control the entry mode and use information 
output memory.

Blip!

The entry display part 
displays the current value 
for “D100”.

The maximum and 
minimum values are also 
displayed because an 
alarm is configured for the 
“D100” entry target.

If an alarm is configured for the entry target, [Max.] and [Min.] are displayed on the overlap.  The 
[Enter] key cannot be pressed if the entered value is outside the displayed range.
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2. Press “3” twice on the keypad.  “33” is displayed on the entry display part.

3. Press the [Enter] key.  The keypad overlap disappears and the value of “D100” displays “33”.  
Checking the “D100” address on the PLC should show that “33” is written.

Writing operations for other data are performed in the same manner.

Entry display part displays 
“33”

D100
D101
D102
D103

33 Dec
0 Dec
 0 Dec
0 Dec

PLC

Entering negative values, such as “-200”:
Press “2” “0” “0” “+/-” and then [Enter] on the keypad.
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2.2 Entering Text

1. Press the character display for “D110”.  This displays the character overlap and highlights the 
value for “D110”.

2. Press “D” “A” “T” “E” using the character entry keys.  “DATE” is displayed on the entry display 
part.

3. Press the [Enter] key.  The character entry overlap disappears and “DATE” is displayed.  
Checking the “D110” and “D111” addresses on the PLC should show that “4144Hex” and 
“4554Hex” are written.

D110
D111
D112
D113

4144 Hex
4554 Hex

 0 Hex
0 Hex

PLC
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Please use this page freely.



5. Alarm Screens

5-1

5

5. Alarm Screens
• Alarm tracking (historical)

Depending on the ON/OFF state of the relevant bit, the corresponding error message and time 
information (occurrence/reset) are displayed on a single line.  This information is stored in the 
buffering area as alarm history.

Configure the following settings for [Alarm Tracking] that stores the alarm history.
- Store the alarm history → Buffering area
- Display the stored alarm history → Alarm tracking parts
- Register error messages → Message editing

• Real time alarm display
History information from alarm tracking can be used to just display the currently occurring 
error.

PLC

TS

D200-00

D200-01

D200-02

D200-03

D200-04

D200-05

D200-06

DWUP -+ DELRET RESET

Menu

                                           16:15:43     16:21:12
                                           16:15:51     16:21:54
                                           16:15:52     16:21:55
                                           17:05:02     18:08:01
                                           17:06:31     18:08:01
                                           19:21:30     21:09:44
                                           19:22:45     21:10:22

16:15:43
16:15:51
16:15:52
16:21:12
16:21:54
16:21:55
17:05:02
17:06:31
18:08:01
18:08:01
19:21:30
19:22:45
21:09:44
21:10:22

#2 Roller error
#1 Sensor error
#1 Roller error
#2 Sensor error
#3 Sensor error
#5 Roller error
#4 Sensor error

#2 Roller error occurred
#1 Sensor error occurred
#1 Roller error occurred
#2 Roller error reset
#1 Sensor error reset
#1 Roller error reset
#2 Sensor error occurred
#3 Sensor error occurred
#2 Sensor error reset
#3 Sensor error reset
#5 Roller error occurred
#4 Sensor error occurred
#5 Roller error reset
#4 Sensor error reset

Alarm Tracking

Buffering area

Changes to data in the PLC memory are 
monitored and stored.

Occurrence/Reset Time

Buffering Area
This area is used to store sampling data.  Select either the internal memory (DRAM/SRAM) of 
the TS Series unit or the external storage device for the storage target.
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Create the following screens in this section.

Contents

Screen Example

Alarm Tracking

Single line display of 
bit ON and OFF times

ON OFF

Message display of the 
currently occurring 
error (bit ON)

Real Time Alarm Display
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1. Placing Parts

This section explains how to place alarm tracking parts.

1. Click [Parts] → [Parts List].  The [Parts List] window is displayed.
2. Select [Alarm Tracking].

3. Select the desired part using the [←] and [→] icons or from the drop-down list.
4. Drag the selected part onto the screen.  This places the alarm tracking part on the screen.

Screen Creation (1)

Drag
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2. Alarm Tracking Parts

The parts that comprise alarm tracking are shown below.
Configure detailed settings via the alarm tracking icon.  For more information on the operational 
specifications of other switches, refer to page 5-34.

In addition to the [Parts List], the following four methods are available for placing parts.
1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1.  Parts icons

2.  [Parts] menu 3.  [Catalog] dialog box 4.  Wizard ([Parts] menu)

Display area

Previous block switch

Roll down switch

Alarm tracking

Roll up switch

Graph return switch

Next block switch

Delete switch
Reset switch
Change display switch
Change display order switch
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3. Alarm Tracking Settings

This section explains how to configure the settings for alarm tracking.

1. Click on the alarm tracking part.  Red handles and a [Link] item dialog box are displayed.

2. Click the alarm tracking icon at the upper left corner of the area.  The [Alarm Tracking] item 
dialog box is displayed.

3. Configure the settings for alarm tracking.

Red handle

Alarm tracking icon
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3.1 [Main] Tab

Configure the following settings.

Item Description Setting 
Value

Buffering Area No. Set the desired buffering area number for storing the alarm 
history.
Setting range: 0 to 11
Set or check the buffering area numbers by clicking the [Refer 
to Buffering Status] button.
For more information, refer to “4. Buffering Area Settings.”

0

Start Message G No. Set the G No. to which alarm messages are registered.
Setting range: 0 to 127
Register or edit messages by clicking [Open].
For more information, refer to “5. Editing Messages.”

0

History Display Set the information to display in the alarm tracking area. Occurrence/
Cancellation 

Time

Date Display This setting is valid when [History Display] is set to “Time of 
Occurrence” or “Occurrence/Cancellation Time”.
Select the format for displaying the date when this checkbox is 
selected.

06/04/01

Year 4-digit Display This setting becomes active when the [Date Display] checkbox 
and a Common Era calendar are selected.
Select this checkbox to use four digits for displaying the year.

Deselected

Zero Suppress for 
Year

This setting becomes active when the [Date Display] checkbox 
and a Common Era calendar are selected.
Set whether to enable zero suppression when displaying the 
year.

Deselected

Zero Suppress for 
Month-Day

This setting becomes active when the [Date Display] checkbox 
and a Common Era calendar are selected.
Set whether to enable zero suppression when displaying the 
month and day.

Deselected

Time Display Select the format for displaying the time when this checkbox is 
selected.

13:30:20

Display Order
Ascending Order
Descending Order

Select a display order.
• Ascending Order

Errors are displayed with the oldest one at the top.
• Descending Order

Errors are displayed with the newest one at the top.

Ascending 
Order

Acknowledge 
function

Select this checkbox to use the acknowledge function. Deselected
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3.2 [Style] Tab

Set the text color and properties of error messages.

3.3 [Detail] Tab

The settings on this tab do not require changing in this section.

This completes the configuration of the alarm tracking settings.  The next section covers buffering 
area configuration.

Item Description Setting 
Value

Color Set the message color. Black

Property
Bold/Shadow/Italic
Transparent/Not 
Transparent

Set the properties and transparency of messages. Transparent

Windows Font Select this checkbox to use a Windows font. Deselected

Item Description Setting 
Value

Only Primary Cause 
Display

Select this checkbox to only display primary cause messages. Deselected

Primary Cause 
Mark Display

Select this checkbox to display a mark (*) to the left of primary 
cause messages.

Deselected

Screen Display
Screen No.

Select this checkbox to change to the details screen by tapping 
an alarm message on the unit.

Deselected

ID Set the ID. 0
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4. Buffering Area Settings

Set the buffering area for storing the alarm history.

1. Click [Refer to Buffering Status] on the [Main] tab in the [Alarm Tracking] dialog box or click 
[System Setting] → [Buffering Area Setting].

2. Configure the settings for buffering area number 0.

The buffering area can be partitioned into a maximum of 12 sections (buffers), numbering 0 to 
11.

or

Sampling settings

Store Target
Discrete memory/CSV format

Others

Sampling control memory
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♦ Sampling Settings

♦ Store Target
Set the storage target for sampling data.

Item Details Setting 
Value

Type
Sampling Method

Set the sampling method.
The type and method are set automatically when an alarm item 
is placed on the screen.

Alarm
Alarm 

Tracking

Sampling Cycle
High Speed

Set the interval for monitoring sampling memory.
Setting range: 0 to 65535 sec

0

Memory
Continuous, 
Individually
Memory address 
specification ON/OFF
Data Length
Word Count

Set the error memory address and total number of words.

Continuous, memory address specification ON:
The sampling memory comprises the consecutive 
addresses starting from the specified memory address.  Set 
the data length of the specified memory address.

Continuous, memory address specification OFF:
The sampling memory comprises the consecutive 
addresses starting from the read area and sampling control 
memory.

Individually:
The sampling memory comprises the specified memory 
address.
A bit memory address can be specified for each error.
Set these addresses on the [Discrete memory/CSV format] 
tab.

Continuous
M00000

Data 
Length
1-Word

Word Count
1

Buffering area 
number 0

Item Details Setting 
Value

Primary storage target
Type

DRAM:
Store sampled data in the DRAM area of the unit.
This area is cleared when the unit changes to STOP mode 
(when the power is turned off or the [Main Menu] screen is 
displayed).

SRAM:
Store sampled data in the SRAM area of the unit.
Data in this area is retained even when the unit changes to 
STOP mode (when the power is turned off or the [Main 
Menu] screen is displayed).

SRAM
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♦ Discrete Memory/CSV Format
Configure the sampling memory settings and data format settings for CSV file output to the 
external storage device when [Memory] is set to “Individually”.

Primary storage target
Full Processing

Set what happens when the specified number of sampling times 
([No. of Samples]) is exceeded.

Overwrite:
Sampling continues even when the number specified for [No. 
of Samples] is exceeded.  Old data is discarded 
automatically.

Stop:
Sampling stops when the number specified for [No. of 
Samples] is exceeded.

Overwrite

Primary storage target
No. of Samples

Set the number of history samples to store in the primary 
storage target.
An error occurrence (bit ON) is counted as one sample and 
error reset (bit OFF) is counted as one sample as well.

If the number of samples is less than the display area size, the 
roll up and roll down switches do not operate.

1000

Secondary storage 
target

Output media

Select “Storage” to store history data in the external storage 
device.
History data is stored in BIN file format.

None

Secondary storage 
target

No. of Samples

Set the number of history samples to store in the external 
storage device.

If the number of samples is less than the display area size, the 
roll up and roll down switches do not operate.

None

Secondary storage 
target

CSV Output

Select this checkbox to convert the secondary storage target 
BIN file to a CSV file and save it to the external storage device.

Deselected

Secondary storage 
target

Create Backup 
File

Save the secondary storage target data in a backup folder. Deselected

Item Details Setting 
Value

Item Details Setting 
Value

Start Message G No., 
No.

Set the message group number to which alarm messages are 
registered.

GNo. 0
No. 0

CSV Format Set the alarm format and date and time format when outputting 
to CSV file.

-

Memory Valid when [Memory] is set to “Individually”.
Set the error bit corresponding to each message.

-
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♦ Others
Configure settings on this tab when using time order alarming, e-mail sending or parameter 
functions.
Since the time order alarming screen is added to page 5-21 “Screen Creation (2)” in this chapter, 
perform the following settings.

♦ Sampling Control Memory/Information Output Memory
The sampling control memory is used to control the buffering area and the information output 
memory is used for outputting the state of the buffering memory.

This completes the configuration of the buffering area settings.

Message
Memorize
E-Mail

Displays the message corresponding to each error bit.
The configuration can be checked when using the e-mail 
sending function.

Double-click on a cell to display the [Message - Edit] window.

-

Parameter Configure the parameter function settings. None

Item Details Setting 
Value

Item Details Setting 
Value

Add Time Order 
Alarming

Choose this setting when using the time order alarming 
function.

Selected

Acknowledge 
function

Choose this setting when using the acknowledge function for 
time order alarming.

Deselected
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5. Editing Messages

This section explains how to register error messages.

1. Click the alarm tracking icon to display its item dialog box.
2. Click [Main] tab → [Open].  The message editing window for the corresponding group number 

is displayed.

Register these 
messages.

Group No.

Memorize/e-mail sending settings

[Next] icon
Change the group number.

Line number

Memory address

Cursor

The [Message - Edit] window can also be displayed with the following method.
Click [Registration Item] → [Message].  The [Message] dialog box is displayed.  Set [Group] to 
“0” and click [OK].

Group No.
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3. Enter the error message.  Sixteen lines of messages can be registered because [Word Count] 

is set to “1” in the [Buffering Area Setting] dialog box.

The line number display can be changed between the actual address (0 to 32767) and the group 
number (0 to 255).

Line No. Message Memory 
Address

00000 Tank A Error M00000

00001 Tank B Error M00001

00002 Tank C Error M00002

00003 Tank D Error M00003

00004 Tank E Error M00004

00005 Tank F Error M00005

00006 Tank G Error M00006

00007 Tank H Error M00007

00008 Valve A Error M00008

00009 Valve B Error M00009

00010 Valve C Error M00010

00011 Valve D Error M00011

00012 Valve E Error M00012

00013 Valve F Error M00013

00014 Valve G Error M00014

00015 Valve H Error M00015

The underline in messages is used to indicate the line feed position.  If an underline is present 
where there are no characters, it indicates that there is a space character present.
The underline can be hidden by clicking [Display] → [Underline] to remove the checkmark.

No underlines
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4. When registration is complete, click [File] menu → [Close].

This completes the message registration process.

The window can 
also be closed by 
clicking here.

or

In message editing there are 128 groups (0 to127) and a maximum of 256 lines of messages 
can be registered in each group (for a maximum of 32768 lines).
A maximum of 127 one-byte characters or 63 two-byte characters can be registered to each 
line.

If [Word Count] is set to a value greater than “16”, one group will not be enough so use the next 
group.
Example:

Word Count: 17 (= 16 bits × 17 words = 272 lines) 
Start Message G No.: 0
With these settings, use “G No. 0 No. 0” to “G No. 1 No. 15”.
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6. SRAM/Clock Settings

SRAM format settings must be configured because [Primary storage target] - [Type] was set to 
“SRAM” for data retention after the power is turned off.  Clock settings must also be configured 
because the clock display is set to use the internal clock of the TS Series unit.

1. Click [System Setting] → [Unit Setting] → [SRAM/Clock].

2. Configure the following settings in the [SRAM/Clock Setting] dialog box.  Do not change any of 
the other settings.

3. Click [OK].  This completes the configuration of the SRAM and clock settings.

Item Details Setting 
Value

Use Built-in Clock Selected:
Use the clock built into the TS Series unit.

Deselected:
Use the clock in the PLC.

Selected

SRAM Auto Format Selected:
Automatically format the SRAM area.

Deselected:
The message “Error:161 (24:) The SRAM area is not 
formatted.” or “The SRAM/clock setting does not match the 
SRAM area format.” is displayed when transferring screen 
data.  In this case, execute [Format of SRAM] on the [Main 
Menu] screen.
For more information on the format procedure, refer to page 
5-28.

Selected

Primary Storage of 
Sampling

Check the amount of SRAM used for the primary storage target. -
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7. Placing Text

This section explains how to place the screen title.

1. Click the [Text] icon.  A cross-shaped cursor is displayed.
2. Click on the screen.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text again to display its item dialog box.  Change the text color and text size 

properties.

The completes the screen editing process.
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8. Checking the Display Area Size

Check how registered messages will be displayed on the unit in V-SFT.

1. Click [View] → [Display Environment].  The [Display Environment] dialog box is displayed.

2. Select the [  Display Message] checkbox in the [Detail] list and click [OK].  This displays the 
messages in the display area.

3. Adjust the size of each part as necessary.  For more information on the adjustment method, 
refer to “8.1 Changing Parts and Adjusting Size.”
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8.1 Changing Parts and Adjusting Size

The part placed in this example links together multiple parts into a single part.  In this linked state, 
all individual parts are moved, enlarged, and reduced together.  The link between these individual 
parts must be canceled in order to move, enlarge, and reduce them separately.  When editing is 
complete, the individual parts can be linked again.

♦ Canceling Links
1. Click on the placed part.  The entire part that includes the display area and switches is 

selected and surrounding with red handles.

2. Click [Link] → [Link Cancel] on the right-click menu.  The handle color changes from red to 
blue and each individual part becomes surrounded by handles.

3. Move, enlarge, or reduce each part as necessary.

Distinguishing Linked Parts
If multiple parts are selected at the same time and surrounded with red handles when clicking on 
a part grouping, these parts are linked together.
Linked parts all share the same ID.

Handles: Red

Handles: Blue
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♦ Changing Parts
Perform the following procedure to change the part design and color.

1. Select the part for changing to display its item dialog box.
2. Click [Style] → [Change Part].  The [Change Part] window is displayed.

3. Select the desired part from the list.

4. Select the part properties for changing and click [Select] to change the part on the screen.

Item Description

Maintain Size Deselected:
Change to the default size.

Selected:
Maintain the size prior to changing.

Pattern Change The pattern image of OFF, ON, and patterns up to P128 can be checked.

Change Part Color Change the color.

Part Type Change Change the part type.
Real/Sign/3D
Circle/Square/Plant/Icon etc.
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♦ Linking Parts
1. Select all the individual parts used in alarm tracking.

2. Click [Link] → [Link] on the right-click menu.  The handle color changes to red and the 
individual parts are linked together.

• Linking cannot be performed if any parts unrelated to alarm tracking are selected.
• Linking individual parts together changes their IDs to the same ID as the alarm tracking icon.  

This ID can be displayed by clicking [Detail] → [ID] on the right-click menu.

• If the ID number differs between individual parts, alarm tracking will not work properly on the 
TS Series unit.

ID 0
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This section explains how to create a real time alarm display using the buffering area configured 
for screen number 3.
This screen will only display errors that are currently occurring.

1. Placing Parts

1. Click [Parts] → [Parts List] or double-click [Parts List] in the [Catalog] dialog box.  The [Parts 
List] window is displayed.

2. Select [Time Order Alarming].
3. Place the linked real time alarm display parts on the screen.

Screen Creation (2)
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2. Real Time Alarm Display Parts

The parts that comprise the real time alarm display are shown below.  Configure detailed settings 
via the real time alarm display icon.  For more information on the operational specifications of other 
switches, refer to page 5-34.

3. Real Time Alarm Display Settings

This section explains how to configure the settings for the real time alarm display.

1. Click on the real time alarm display part.  Red handles and a [Link] item dialog box are 
displayed.

Display area Roll downReal time alarm display icon

Roll up

Change display order switch

Red handle
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2. Click the real time alarm display icon at the upper left corner of the area.  The [Time Order 
Alarming] dialog box is displayed.

3. Configure the settings for the real time alarm display.

♦ [Main] Tab
Configure the following settings.

Real time alarm display icon

Item Description Setting Value

Buffering Area No. Set the desired buffering area number for storing the alarm 
history.
Use the setting from “Screen Creation (1)”.

0

Action Area Set the position to display error messages on the screen. Display Area

Time Display Deselected:
Only display error messages.

Selected:
Display the time that errors occur and the corresponding 
messages.
Max. 15 one-byte characters for time display  04/01 13:30:20

Selected

Display Order
Chronological 
Order
Newest Order

Select a display order.
• Chronological Order

Errors are displayed with the oldest one at the top.
• Newest Order

Errors are displayed with the newest one at the top.

Chronological 
Order
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♦ Do not change the settings on the [Sub-action], [Style], and [Detail] tabs 
in this section.

This completes the configuration of the real time alarm display settings.

4. Placing Text

This section explains how to place the screen title.

1. Click the [Text] icon.  A cross-shaped cursor is displayed.
2. Click on the screen.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box.  Change the text color and text size properties.

Use the settings in 
Buffering Area for 
the message 
settings

Deselected:
Set the destination for registering error messages using the 
start message.

Selected:
Use the message specified with the buffering area number.

Selected

Item Description Setting Value
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5. Creating a Switch for Changing to Another Screen

This section explains how to place a switch that changes between screen 3 (created in “Screen 
Creation (1)”) and screen 4 (created in “Screen Creation (2)”) when pressed.

1. Place a switch.
2. Set [Function] to “Screen” in the switch’s item dialog box and set [Screen No.] to the number of 

the destination screen.

3. Adjust the switch color and position.

This completes the screen creation process.  The next section covers confirming screen operation 
on the TS Series unit.

Switch
Function: Screen 4

Switch
Function: Screen 3

Screen Creation (1)

Screen Creation (2)
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1. Memory Addresses and Registered Messages

The memory addresses used in this example are listed below.

Confirming Unit Operation

Memory 
Address Memory Contents Message

D00000
Read area

-
D00001
D00002
D00003-00

Sampling control memory
(Buffer No. 0)

-
D00003-01
D00003-02
D00003-03
M00000

Sampling memory

GNo. 0 No. 0 Tank A Error

M00001 GNo. 0 No. 1 Tank B Error

M00002 GNo. 0 No. 2 Tank C Error

M00003 GNo. 0 No. 3 Tank D Error

M00004 GNo. 0 No. 4 Tank E Error

M00005 GNo. 0 No. 5 Tank F Error

M00006 GNo. 0 No. 6 Tank G Error

M00007 GNo. 0 No. 7 Tank H Error

M00008 GNo. 0 No. 8 Valve A Error

M00009 GNo. 0 No. 9 Valve B Error

M00010 GNo. 0 No. 10 Valve C Error

M00011 GNo. 0 No. 11 Valve D Error

M00012 GNo. 0 No. 12 Valve E Error

M00013 GNo. 0 No. 13 Valve F Error

M00014 GNo. 0 No. 14 Valve G Error

M00015 GNo. 0 No. 15 Valve H Error

$u16340-00

Info output memory (Buffer No. 0)

-
$u16340-01
$u16340-02
$u16340-03
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1.1 Sampling Control Memory

The sampling control memory is used to control the operation and state of the buffering area 
function.  The allocation and contents of sampling control memory differ in the following manner 
according to the buffering area settings.

In this example, [Buffering Area separate settings] are not set, so memory from the [Read Area] is 
allocated consecutively in 3 word blocks from “D0”.  In addition, the sampling control memory 
becomes bit numbers “00” through “03” of “D00003” because buffer number 0 is being used.

• Buffering Area separate settings: Not set
Memory from the [Read Area] is allocated consecutively in 3 word blocks from “D0”.

The details of each bit are described below.
T: Trigger

This bit is not used when [Type] is set to “Alarm”.
R: Reset

When this bit is set to “ON”, data in the specified buffer is cleared and sampling stops.  
When this bit is set to “OFF”, sampling is started.

S: Normal operation bit
This bit is only valid when [Type] is set to “Alarm” and [Sampling Method] is set to “Alarm 
Tracking”.  This bit is used to obtain more detailed alarm information by performing control 
in conjunction with the state of the sampling bit.

U: Sampling bit
This bit is only valid when [Type] is set to “Alarm” and [Sampling Method] is set to “Alarm 
Tracking”.  This bit is used to obtain more detailed alarm information by performing control 
in conjunction with the state of the normal operation bit.

1.2 Sampling Memory

This error memory is used for monitoring in order to store alarm history.  The memory used differs 
depending on the setting of the [Memory] checkbox ( ) in the [Buffering Area Settings] dialog 
box.

In this example, the sampling memory is “M00000” to “M00015” because the [Memory] checkbox 
is selected, the memory address is set to “M00000”, and [Data Length] is set to “1-Word”.

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00

U S R T U S R T U S R T U S R T

MSB LSB

Sampling control memory

Where “n” is the read area:
n + 3
n + 4
n + 5

Buffer No. 0
Buffer No. 4
Buffer No. 8

Buffer No. 1
Buffer No. 5
Buffer No. 9

Buffer No. 2
Buffer No. 6
Buffer No. 10

Buffer No. 3
Buffer No. 7
Buffer No. 11

Buffering Area separate settings: Set
The four least significant bits in the specified memory are used for control.

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00

0 0 0 0 0 0 0 0 0 0 0 0 U S R T

MSB LSB
Sampling control memory

Specified memory

Buffer No. n
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2. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

2.1 SRAM Format/Clock Settings

The message “Error:161 (24:)” is displayed immediately after transferring screen data to a new 
unit.  In this case, execute [Format of SRAM] on the [Main Menu] screen.  Also configure the 
settings for the built-in clock on the same screen.

1. The message “Error:161 (24:) The screen data does not match the SRAM area format.” is 
displayed after transferring screen data to the unit.

Subsequent screen data transfers to units that have been formatted will not result in this error.*1
SRAM data is retained until the battery in the unit runs out.  If the unit is turned off when the 
battery has run out, the SRAM data is erased.  In this case, reformat the SRAM area.
Unit SRAM Area

*1 The case when the [  SRAM Auto Format] checkbox is selected in the [SRAM/Clock Setting] dialog 
box.

SRAM
0

128kbyte

SRAM

Perform formatting
(Main Menu)

$L

$LD

Unformatted
(new unit/dead 

battery) Sampling
primary storage 

target

Not used

Error occurs Normal

Data Loading...

The screen data does not match the SRAM area format.
Error:161(24: )
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2. Press and hold your finger on any of the four screen corners (2 cm squares) for more than two 
seconds and then release your finger.

3. Next, press any of the remaining corners for more than two seconds within one second of 
releasing the first corner to display a system menu on the right side of the screen.

4. Press the [MODE] switch.  The [Main Menu] screen is displayed.

5. Press the [Main Menu] switch and then press [SRAM/Clock].  The [SRAM/Clock Adjustment] 
screen is displayed.

Data Loading...
2cm

2cm

The screen data does not match the SRAM area format.
Error:161(24: )

Data Loading...
2cm

2cm

The screen data does not match the SRAM area format.
Error:161(24: )

System menu
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6. Press the [Format] switch and then press the [Execute] switch.  A “** Format Completed **” 
message is displayed.

7. Under [Date and Time Adjustment] on the same screen, set the correct date and time and 
press [Set].
The date and time at the upper right of the screen are updated.

8. Press the [Return] switch to return to the [Main Menu] screen.  The error message disappears.
9. Press the [Main Menu] switch and then press the [RUN] switch.  The screen is displayed.
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2.2 Executing Sampling

1. An error occurred on tank A (“M00000” error bit turned ON).
The message “Tank A Error” and the time of occurrence are displayed.

2. An error occurred on tank B (“M00001” error bit turned ON).
The message “Tank B Error” and the time of occurrence are displayed.

3. An error occurred on valve H (“M00015” error bit turned ON).
The message “Valve H Error” and the time of occurrence are displayed.

PLC

TS

M15 M0

PLC

TS

M15 M0

PLC

TS

M0M15
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4. Errors occurred on valves C, D, and E (“M00010”, “M00011”, and “M00012” error bits turned 
ON).
The messages “Valve C Error”, “Valve D Error” and “Valve E Error” and the times of 
occurrence are displayed.

5. The error on tank A was reset (“M00000” turned OFF).  The reset time of the “Tank A Error” is 
displayed.

6. The error on tank B was reset (“M00001” turned OFF).  The reset time of the “Tank B Error” is 
displayed.

PLC

TS

M15 M0

PLC

TS

M15 M0

PLC

TS

M15 M0
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7. The error on valve D was reset (“M00011” turned OFF).  The reset time of the “Valve D Error” 
is displayed.
The messages of errors that have not been reset are for valves C, E, and H.

8. Change the screen using the [Screen3] switch.  Only the error messages for the errors that 
have not been reset are displayed.

PLC

TS

M15 M0

PLC

TS

M15 M0
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2.3 Operating Switches

Use switches to check the error history.

1. Press the switches on the right side of the area.  A cursor is displayed.  The graph return 
switch flashes.

2. The roll up and roll down switches can move the cursor and next block and previous block 
switches can change between pages.

3. Pressing the graph return switch causes the cursor to disappear and returns to the latest 
display.

Cursor

Move the cursor down with 
the roll up switch.

Cursor
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4. Press the [Delete] switch with the cursor on screen.

5. The selected history entry is deleted.
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♦ Switch Functions
The following switch functions are used in alarm tracking and real time alarm display.

4

6 7 8 9

2

5

1

3

No Function Description Alarm Relay

1 Roll up Scroll one line toward the newest history entry.  If all entries cannot 
be displayed at once, one entry scrolls into view at a time.

2 Roll down Scroll one line toward the oldest history entry.  If all entries cannot 
be displayed at once, one entry scrolls into view at a time.

3 Next block Scroll one page toward the newest history entry.

4 Previous block Scroll one page toward the oldest history entry.

5 Graph return This button flashes in conjunction with the cursor when any of the 
roll up, roll down, next block, or previous block switches are 
pressed.  Pressing this switch when it is flashing returns to the 
latest display where the switch stops flashing and the cursor 
disappears.

6 Change DISPOrder Change the display order between ascending order and 
descending order.

7 Display 
Change-over

This switch is only available when the [  Date Display] checkbox 
or the [  Time Display] checkbox is selected in the [Alarm 
Tracking] dialog box (page 5-5).
Pressing this switch changes between date display and time 
display.

8 Reset Press this switch once to turn on its lamp and then press it again 
within two seconds to clear the contents of the buffering area.  
Sampling starts again immediately after the buffering area is 
cleared.
If the switch is not pressed again within two seconds, the switch’s 
lamp turns off and resetting is nullified.

9 DELETE Delete the history entry selected with the cursor.
This operation only removes the entry from the display area and 
does not affect the total frequency of occurrence display or total 
time of occurrence display.
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6. Trend Screen (Trend Sampling)

This section explains how to use trend sampling to display line graphs of data that changes over 
time.  Trend sampling accumulates changing data in the buffering area so that previous data can 
be checked for trends.

Trend sampling can display a maximum of 16 graph lines in a single area.

Configure the following two settings in order to use trend sampling.
• Accumulate changing data → Buffering area settings
• Display accumulated data → Trend sampling settings

TS PLC

D200

D20116:15:43
16:15:51
16:15:52
16:21:12
16:21:54
16:21:55
17:05:02
17:06:31
18:08:01
18:08:01
19:21:30
19:22:45

(D201)
80
40

290
120
190

75
200
120
280
120
115
120

(D200)
300
250
360
340
360
310
310
320
380
320
360
350

00

400

ResetReturn

Trend Sampling

Buffering Area
This area is used to store sampling data.  Select either the internal memory (DRAM/SRAM) of 
the TS Series unit or the external storage device for the storage target.
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Screen Example.................................................................................................................. page 6-2
Screen Configuration .......................................................................................................... page 6-3

1. Placing Parts............................................................................................................. page 6-3
2. Trend Sampling Parts ............................................................................................... page 6-4
3. Trend Sampling Settings .......................................................................................... page 6-5
4. Adjusting the Display Area Size ............................................................................. page 6-15
5. Buffering Area Settings........................................................................................... page 6-15
6. SRAM/Clock Settings ............................................................................................  page 6-23
7. Placing Text ............................................................................................................ page 6-24

Checking Operation on the Unit ........................................................................................ page 6-25
1. Memory Addresses................................................................................................. page 6-25
2. Unit Operation ........................................................................................................ page 6-27

Create the following screen in this section.

Contents

Screen Example
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1. Placing Parts

Place the trend sampling part on the screen.

1. Click [Parts] → [Parts List].
2. Select [Trend Sampling].

3. Select the part using the [←] and [→] icons or from the drop-down list.
4. Drag the selected part onto the screen.  This places the trend sampling part on the screen.

Screen Configuration

Drag
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2. Trend Sampling Parts

The parts that comprise trend sampling are shown below.

In addition to the [Parts List], the following four methods are available for placing parts.
1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1.  Parts icons

2.  [Parts] menu 3.  [Catalog] dialog box 4.  Wizard ([Parts] menu)

Sampling count display
Cursor point value display

Trend sampling

Reset switch
Next block switch
Roll up switch
Roll down switch
Previous block switch
Return switch

Reduce display
Enlarged display
Sampling time 
display
(start point of display)

Sampling time display
(end point of display)

Sampling time display
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3. Trend Sampling Settings

Configure the settings for trend sampling.

1. Click the trend sampling area on the screen.  The [Link] item dialog box is displayed.

2. Click on display area again.  The [Trend Sampling] item dialog box is displayed.

3. Configure the settings for trend sampling.
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3.1 [Main] Tab

Set the number of graph lines and the number of plot points.

Item Details Setting 
Value

Buffering Area No. Set the buffering area number for storing data.
Setting range: 0 to 11
Set or check the buffering area numbers by clicking the [Refer to 
Buffering Status] button.
For more information, refer to “Buffering Area Settings” on page 
6-19.

1

X Axis Data Points Set the number of points used to display data.
Setting range: 3 to 800

Set the number of points to less than the size of the display area.

13

Graph Setting
No.0 to 15

Set the number of graph lines.
Setting range: 0 to 15
Configure the settings for each graph using the [Edit] button.
For more information, refer to “Graph Settings” (page 6-7).

No.0
No.1

Selected

Direction Set the direction to draw graph lines. →

1 2 3

Point

Y

Y

Y

Y

X X

X X

Coordinate 
origin

[→]

[↓][↑]

[←]
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♦ Graph Settings
Set the properties of each graph line.

• Graph No. 0 • Graph No. 1

Item Details
Graph No. 0

Setting 
Value

Graph No. 1
Setting 
Value

Sampling Buffer Word 
No.

Set which word of data to display as a trend from the data 
stored in the buffering area.
Setting range: 0 to 128

* For more information on buffering area settings, refer to page 
6-19.

0 1

Data Length Set the data length of the sampling data.
Setting range: 1-Word/2-Word

1 1

Graph Min. Value Set the minimum and maximum values for sampling data.
Select constants for a fixed range and memory for a variable 
range.
Setting range:

1-Word: -32768 to 32767
2-Word: -2147483648 to 2147483647

0 0

Graph Max. Value 40 100

Line Graph
Marker

Set the line type or point type in addition to color. Solid line
Black

Dotted line
Blue

Buffering Area Settings
Word Count*

Sampling Buffer Word 
No.

2-Word 0

1

[Set Selected] Button
The [Set Selected] button is convenient to use when the settings required for data length, graph 
minimum value, and graph maximum value are all the same.
1. Select the number checkboxes of all the trends for use.
2. Click the [Set Selected] button.  The [Set Selected] 

dialog box is displayed.
3. Set values for [Data Length], [Graph Min. Value], 

and [Graph Max. Value] and click [OK].  This 
configures the [Data Length], [Graph Min. Value], 
and [Graph Max. Value] settings for the selected 
trend numbers all at once.
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3.2 [Reference Line] Tab

Lines of reference can be displayed on the graph area.  A maximum of four lines can be displayed 
at once.  This function is not used in this example.

3.3 [Style] Tab

Settings such as area color can be configured.  These settings are not changed in this example.

3.4 [Scale] Tab

Graphs can display a scale along the right, left, top, or bottom side.
In this example, scales are displayed along the right, left, and bottom sides.

Item Details Setting 
Value

Set scale display Select this checkbox to display scales. Selected

Color
Back Color

Set the color of the major and minor tick marks and axis lines of 
the scale.
This setting is common to all left, right, bottom, and top sides.

Color: 
Black

Back Color: 
White

Length of small scale Set the length of the minor tick marks of the scale.
This setting is common to all left, right, bottom, and top sides.
Range: 1 to 16
The thickness of the markings is fixed.

Deselected

Left
Right
Bottom
Top

Select the corresponding checkboxes on these tabs to display a 
scale, grid lines, and numbers.
For more information, refer to the next page.

Left
Right

Bottom
Selected

Minor tick 
marks
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♦ [Left] Tab

Item Details Setting 
Value

Scale Set whether to display a scale. Selected

• Selected • Deselected
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Small scale alignment • Equal divide (unit based on [No. of divisions])
Minor tick marks are equally spaced according to the set 
number of divisions along the axis line.

• Equal interval (unit based on [No. of intervals])
Minor tick marks are spaced at the specified interval based on 
the range (maximum and minimum values of the specified 
graph or an arbitrary setting value) set under [Range 
Setting].*1

Equal 
divide

8

Make small scales 
larger every n 
scales.

Select this checkbox to display major tick marks.
The major tick mark is twice the length of the minor.  The thickness 
of the markings is fixed.

Selected

Every 2 
marks

Grid Line
Color
Line Type

Display only 
large scale

Select this checkbox to display grid lines at the positions of major 
and minor tick marks of the scale.
Set the color and line type of grid lines.
It is possible to only display grid lines at the positions of major tick 
marks.

Selected

Color:
White

Display 
only large 

scale
Selected

Item Details Setting 
Value

No. of 
Divisions: 4

25

25

25

25

25

0

50

75

100

1

1

1

1

1

0

2

3

4

Interval: 25
Graph No. 0

Graph Min. Value: 0
Graph Max. Value: 100

Interval: 1
Scale value: 0 to 4

Major tick 
marks

• Major tick marks only • Major/minor tick marks
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♦ [Right] Tab
These settings are the same as for the [Left] tab.  In this example, configure the following settings.

Num. Display Select this checkbox to display reference values based on the 
range (maximum and minimum values of the specified graph or an 
arbitrary setting value) set under [Range Setting].*1

Selected

Black

Display 
only large 

scale
Selected

Range Setting Settings in this area are valid when [Small scale alignment] is set 
to “Equal interval” and the [  Num. Display] checkbox is selected.
Refer to the setting of each option.

Match with 
the 

specified 
graph
No. 0

*1 When the graph direction is [↑/↓], numbers are displayed based on the setting of [X Axis Data 
Points] on the [Main] tab or [Set values] under [Range Setting].

Item Details Setting 
Value

25

0

50

75

100

1

0

2

3

4

Interval: 25
Graph No. 0
Graph Min. Value: 0
Graph Max. Value: 100

Interval: 1
Scale value: 0 to 4

Item Setting Value

Scale Selected

Small scale alignment Equal divide
4

Make small scales larger every n scales. Deselected

Grid Line
Color
Line Type

Display only large scale

Deselected

Num. Display Selected
Blue

Range Setting Match with the specified graph
No. 1
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♦ [Bottom] Tab

Item Details Setting 
Value

Scale Set whether to display a scale. Selected

Small scale alignment • Equal divide (unit based on [No. of divisions])
Minor tick marks are equally spaced according to the set 
number of divisions along the axis line.

• Equal interval (unit based on [No. of intervals])
Minor tick marks are spaced at the specified interval based 
on the setting of [X Axis Data Points] on the [Main] tab or 
the range of [Set values] under [Range Setting].*1

Equal 
divide

12

• Selected • Deselected

No. of Divisions: 4

2 2 2 2 2

100 2 4 6 8

5 5 5 5

200 5 10 15

Interval: 2
X Axis Data Points: 11

Interval: 5
Range: 0 to 20
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♦ [Top] Tab
These settings are the same as for the [Bottom] tab.  These settings are not used in this example.

Make small scales 
larger every n 
scales.

Select this checkbox to display major tick marks.
The major tick mark is twice the length of the minor.  The 
thickness of the markings is fixed.

Selected

Every 3 
marks

Grid Line
Color
Line Type

Display only 
large scale

Select this checkbox to display grid lines at the positions of 
major and minor tick marks of the scale.
Set the color and line type of grid lines.
It is possible to only display grid lines at the positions of major 
tick marks.

Selected

White

Display 
only large 

scale
Selected

Num. Display Select this checkbox to display reference values based on the 
setting of [X Axis Data Points] on the [Main] tab or the range of 
[Set values] under [Range Setting].*1

Selected

Black

Range Setting Settings in this area are valid when [Small scale alignment] is 
set to “Equal interval” and the [  Num. Display] checkbox is 
selected.
Refer to the setting of each option.

Match with 
the 

specified 
graph
No. 0

*1 When the graph direction is [↑/↓], numbers are displayed based on the range (maximum and 
minimum values of the specified graph or an arbitrary setting value) set for [Range Setting] .

Item Details Setting 
Value

Major tick marks

• Display only large scale • Major/minor tick marks

200 5 10 15100 2 4 6 8

Interval: 2
X Axis Data Points: 11

Interval: 5
Range: 0 to 20



6. Trend Screen (Trend Sampling)

6-14

3.5 [Detail] Tab

Configure the settings for displaying or hiding trend sampling as well as zooming in and out of the 
graph.

Item Details Setting 
Value

Use Control Memory This memory address is associated with displaying or hiding graph 
line numbers 0 to 15.
Each graph line is displayed or hidden when the corresponding bit is 
set (ON) or reset (OFF).

Deselected

Zooming in and out
Internal
External/Command 
Memory

These are the settings for zooming in and out of graphs.
• Internal

Use switches for zooming in and out.
Zooming in: actual size → 2 times → 4 times → 8 times
Zooming out: 8 times → 4 times → 2 times → actual size

• External
The graph is zoomed in or out according to the value specified 
in the command memory.
0: Actual size
1: 2 times
2: 4 times
3: 8 times

Internal

Process Cycle
High Speed, Low 
Speed, Refresh

Set the read cycle for the command memory.  Redrawing is 
performed at the following timings.

• High Speed
Every cycle

• Low Speed
Once in several cycles
One cycle when the screen is opened
At the leading edge (0 → 1) of bit 15 (data read refresh) in read 
area “n + 1”

• Refresh
At the leading edge (0 → 1) of bit 15 (data read refresh) in read 
area “n + 1”
Macro command TREND_REFRESH

-

ID Set the ID.  All the parts used in trend sampling must be set to the 
same ID.

• Switches
Roll Up/Roll Down/Next Block/Previous Block/Reset/Graph 
Return/Zoom In/Zoom Out

• Number display
Sample count display/sample time display/cursor value display

• Display area

0

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00

Graph No. 15

Graph No. 3

Graph No. 2

Graph No. 1

Graph No. 0
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4. Adjusting the Display Area Size

The size of the required display area in trend sampling changes depending on the setting for [X 
Axis Data Points].  For this reason, size adjustment must be performed after settings are 
configured.

The part placed in this example links together multiple parts into a single part.  In this linked state, 
all individual parts are moved, enlarged, and reduced together.  The link between these individual 
parts must be canceled in order to select them separately.  When editing is complete, the individual 
parts can be linked again.

♦ Canceling Links
1. Click on the placed part.  The entire part that includes the display area and switches is 

selected and surrounded with red handles.

Point

Y
 s

iz
e

Plot point pitch

X size
Blank area

Distinguishing Linked Parts
If multiple parts are selected at the same time with red handles when clicking on a part, these 
parts are linked together.
Linked parts all share the same ID.

Handles: Red
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2. Click [Link] → [Link Cancel] on the right-click menu.  The handle color changes from red to 
blue and each individual part becomes surrounded by handles.
Adjust the size, change parts, and move parts as required.

Handles: Blue
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♦ Size Adjustment
1. Click the trend sampling display area.

2. Place the mouse cursor over a handle located on a margin.  The mouse cursor changes to a 
↔ mark.

3. Drag the handle with the mouse cursor displayed as ↔.  The size is adjusted automatically.

End point

Margin

Mouse cursor

Margin

Drag in the ← direction

No margin

Drag in the → direction
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♦ Linking Parts
1. Select all the individual parts used in trend sampling.

2. Click [Link] → [Link] on the right-click menu.  The handle color changes to red and the 
individual parts are linked together.

• Linking cannot be performed if any parts unrelated to trend sampling are selected.
• Linking individual parts together changes their IDs to the same ID as the trend sampling 

icon.  This ID can be displayed by clicking [Detail] → [ID] on the right-click menu.

• If the ID number differs between individual parts, trend sampling will not work properly on 
the TS Series unit.

ID 0
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5. Buffering Area Settings

Set the buffering area for storing the trend sampling history.  Use buffering area number 1 in this 
example because buffering area number 0 is used for alarms.

1. Click [Refer to Buffering Status] on the [Main] tab in the [Trend Sampling] dialog box or click 
[System Setting] → [Buffering Area Setting].

2. Configure the settings for buffering area number 1.

The buffering area can be partitioned into 12 sections, numbering 0 to 11.

or

Sampling settings

Store Target
Discrete Memory/CSV Format

Others

Sampling control memory
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♦ Sampling Settings

♦ Store Target
Set the storage target for sampling data.

Item Details Setting 
Value

Type
Sampling Method

Set the sampling method.

Bit Synchronization:
Data is stored at the edge of the OFF → ON trigger bit.

Constant Sampling:
Data is stored at the specified interval (= [Sampling Cycle]).

Trend
Bit 

Synchroniz
ation

Sampling Cycle
High Speed

Set the interval for monitoring sampling memory and the trigger bit.
Setting range: 0 to 65535 sec

0

Memory
Continuous, 
Individually
Memory address 
specification 
ON/OFF
Data Length
Word Count

Set the sampling memory address and total number of words.

Continuous, memory address specification ON:
The sampling memory comprises the consecutive addresses 
starting from the specified memory address.  Set the data length 
of the specified memory address.

Continuous, memory address specification OFF:
The sampling memory comprises the consecutive addresses 
starting from the read area and sampling control memory.

Individually:
The sampling memory comprises the specified memory address.
Set these addresses on the [Discrete memory/CSV format] tab.

Continuous
D200

Data 
Length
1-Word

Word Count
2

Buffering area 
number 1

Item Details Setting 
Value

Primary storage target
Type

DRAM:
Store sampled data in the DRAM area of the unit.
This area is cleared when the unit changes to STOP mode 
(when the power is turned off or the [Main Menu] screen is 
displayed).

SRAM:
Store sampled data in the SRAM area of the unit.
Data in this area is retained even when the unit changes to 
STOP mode (when the power is turned off or the [Main 
Menu] screen is displayed).

SRAM
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♦ Discrete Memory/CSV Format
Configure the sampling memory settings and data format settings for CSV file output to the 
external storage device when [Memory] is set to “Individually”.

♦ Others
Configure settings on this tab to use calculation functions (mean values, total values, etc.) on the 
sampling data.
The settings on this tab do not need to be changed in this section.

Primary storage target
Full Processing

Set the action to take when the specified number of sampling 
times ([No. of Samples]) is exceeded.

Overwrite:
Sampling continues even when the number specified for 
[No. of Samples] is exceeded.  Old data is discarded 
automatically.

Stop:
Sampling stops when the number specified for [No. of 
Samples] is exceeded.

Overwrite

Primary storage target
No. of Samples

Set the number of history samples to store in the primary 
storage target.

If the number of samples is less than the display area size, the 
roll up and roll down switches do not operate.

1000

Secondary storage 
target

Output media

Select “Storage” to store history data in the external storage 
device.
History data is stored in BIN file format.

None

Secondary storage 
target

No. of Samples

Set the number of history samples to store in the external 
storage device.

If the number of samples is less than the display area size, the 
roll up and roll down switches do not operate.

None

Secondary storage 
target

CSV Output

Select this checkbox to convert the secondary storage target 
BIN file to a CSV file and save it to the external storage device.

Deselected

Secondary storage 
target

Create Backup File

Save the secondary storage target data in a backup folder. Deselected

Item Details Setting 
Value

Item Details Setting 
Value

CSV Format Set the date and time format when outputting CSV files to the 
external storage device.

-

Memory Valid when [Memory] is set to “Individually”.
Set the sampling memory address.

-

Type/Decimal Point
Data Length/Characters
Text Process

Set the data type of the specified memory address. -
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♦ Sampling Control Memory/Information Output Memory
The sampling control memory is used to control the buffering area and the information output 
memory is used for outputting the state of the buffering memory.

This completes the configuration of the buffering area settings.
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6. SRAM/Clock Settings

SRAM format settings must be configured because [Primary storage target] - [Type] was set to 
“SRAM” for data retention after the power is turned off.  Clock settings must also be configured 
because the clock display is set to use the internal clock of the TS Series unit.

1. Click [System Setting] → [Unit Setting] → [SRAM/Clock].

2. Configure the following settings in the [SRAM/Clock Setting] dialog box.  Do not change any of 
the other settings.

3. Click [OK].  This completes the configuration of the SRAM and clock settings.

Item Details Setting 
Value

Use Built-in Clock Selected:
Use the clock built into the TS Series unit.

Deselected:
Use the clock in the PLC.

Selected

SRAM Auto Format Selected:
Automatically format the SRAM area.

Deselected:
The message “Error:161 (24:) The SRAM area is not 
formatted.” or “The SRAM/clock setting does not match the 
SRAM area format.” is displayed when transferring screen 
data.  In this case, execute [Format of SRAM] on the [Main 
Menu] screen.
For more information on the format procedure, refer to 
“SRAM Format/Clock Settings” on page 5-28.

Selected

Primary Storage of 
Sampling

Check the amount of SRAM used for the primary storage target. -
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7. Placing Text

Place text on the trend sampling screen.

1. Click the [Text] icon.  A cross-shaped cursor is displayed.
2. Click on the screen.  A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text again to display its item dialog box.  Change the text color and text size 

properties.

This completes the screen editing process.

Text
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1. Memory Addresses

The memory addresses used in this example are listed below.

Checking Operation on the Unit

Memory 
Address Memory Contents

D00000
Read areaD00001

D00002
D00003-04

Sampling control memory
(Buffer No. 1)

T: Trigger
D00003-05 R: Reset
D00003-06 Not used
D00003-07 U: Start bit
D00200 Sampling memory (Buffer Word No. 0)
D00201 Sampling memory (Buffer Word No. 1)
$u16340-04

Info output memory (Buffer No. 1)
$u16340-05
$u16340-06
$u16340-07
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1.1 Sampling Control Memory

The sampling control memory is used to control the operation and state of the buffering area 
function.  Allocation and the contents of sample control memory differ depending on settings.

In this example, [Buffering Area separate settings] are not set, so memory from the [Read Area] is 
allocated consecutively in 3 word blocks from “D0”.  In addition, the sampling control memory 
becomes bit numbers “04” to “07” of “D00003” because buffer number 1 is being used.

The details of each bit are described below.
T: Trigger

This bit is only valid when [Type] is set to “Trend” and [Sampling Method] is set to “Bit 
Synchronization”.  History is stored when this bit is “ON”.

R: Reset
When this bit is set to “ON”, data in the specified buffer is cleared and sampling stops.  
When this bit is set to “OFF”, sampling is started.

S: Normal operation bit
This bit is not used when [Type] is set to “Trend”.

U: Start bit
This bit is only valid when [Type] is set to “Trend” and [Sampling Method] is set to 
“Constant Sampling”.
Sampling is performed while this bit is set to “ON”.

1.2 Sampling Memory

This memory stores the sampling data.  The memory used differs depending on the setting of the 
[Memory] checkbox ( ) in the [Buffering Area Settings] dialog box.

In this example, the sampling memory is “D00200” to “D00201” because the [Memory] checkbox is 
selected, the memory address is set to “D200”, and [Data Length] is set to “2-Word”.

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00

U S R T U S R T U S R T U S R T

MSB LSB
Sampling control memory

Where “n” is the read area:
n + 3
n + 4
n + 5

Buffer No. 0
Buffer No. 4
Buffer No. 8

Buffer No. 1
Buffer No. 5
Buffer No. 9

Buffer No. 2
Buffer No. 6
Buffer No. 10

Buffer No. 3
Buffer No. 7
Buffer No. 11

Buffering Area separate settings: Set
The four least significant bits in the specified memory are used for control.

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00

0 0 0 0 0 0 0 0 0 0 0 0 U S R T

MSB LSB
Sampling control memory

Specified memory

Buffer No. n
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2. Unit Operation

This section explains how to check screen operation after transferring screen data to the unit.

2.1 SRAM Format/Clock Settings

The message “Error:161 (24:)” is displayed immediately after transferring screen data to a new 
unit.  In this case, execute [Format of SRAM] on the [Main Menu] screen.  Also configure the 
settings for the built-in clock on the same screen.

For more information on the formatting procedure, refer to “SRAM Format/Clock Settings” on page 
5-28.

Subsequent screen data transfers to units that have been formatted will not result in this error.*1
SRAM data is retained until the battery in the unit runs out.  If the unit is turned off when the 
battery has run out, the SRAM data is erased.  In this case, reformat the SRAM area.
Unit SRAM Area

*1 The case when the [  SRAM Auto Format] checkbox is selected in the [SRAM/Clock Setting] dialog 
box.

SRAM
0

128kbyte

SRAM

Perform formatting
(Main Menu)

$L

$LD

Unformatted
(new unit/dead 

battery) Sampling
primary storage 

target

Not used

Error occurs Normal
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2.2 Executing Sampling

Execute sampling according to the following procedure.

1. Enter the following constants for “D00200” and “D00201”.
D00200 = 17
D00201 = 90

2. Set the “D00003-04” bit in sample control memory to “ON” (0 → 1).
D00003 = H0010

The sample time display and sample count display appear as shown below.

3. Set the “D00003-04” bit to “OFF” (1 → 0).
D00003 = H0000

4. Set the “D00003-04” bit to “ON” again (0 → 1).
D00003  = H0010
The trends are displayed.  The sample time is updated and the sample count display indicates 
“2”, as shown below.

Sampling count display Sampling time display

Sampling count display Sampling time display
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5. Proceed to sample the following data.

Sample Count
Sampling Data Memory

D00200 D00201

3 16 65

4 16 70

5 15 75

6 15 80

7 16 70

8 17 65

9 18 60

10 19 55

11 20 50

12 21 45

13 22 40

14 25 38

15 24 40

16 23 45

17 22 50

18 21 55

19 20 60

20 19 62

21 18 65

22 18 65

23 17 60

24 17 60

Display example where count is “24”
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2.3 Operating Switches

Use the switches on screen to check history data.

♦ Roll Up and Roll Down
1. Press the roll down switch.  A cursor is displayed in the center of the graph and the [Graph 

Return] switch starts to flash.  The sample count, cursor value, and sample time of the data 
selected at the cursor is displayed.

2. Pressing the roll down switch again moves the selection cursor to the left.
The sample count, cursor value, and sample time are updated.

3. Pressing the [Graph Return] switch causes the cursor to disappear and returns to the latest 
display.

Roll down switchFlashing

Sample count

Sample timeCursor value

Cursor

Cursor
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♦ Zoom In and Zoom Out
Press the [Zoom In] switch to enlarge the display of the latest data (end point) by 2 times.
Each time the switch is pressed, magnification increases to 4 times and then 8 times (maximum).
Press the [Zoom Out] switch to reduce the display magnification in the order of 8 times → 4 times 
→ 2 times → actual size.

If the cursor is displayed, magnification centers on the cursor.

2 times magnification

Actual size

Cursor
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♦ Switch Functions
The following switch functions are used in trend sampling.

1 Roll up Scroll one point toward the newest data.  If all data points cannot be 
displayed in the area, one data point scrolls into view at a time.

2 Roll down Scroll one point toward the oldest data.  If all data points cannot be 
displayed in the area, one data point scrolls into view at a time.

3 Next block Scroll one page toward the newest data.

4 Previous block Scroll one page toward the oldest data.

5 Graph Return This button flashes in conjunction with the cursor when any of the roll up, 
roll down, next block, or previous block switches are pressed.  Pressing 
this switch when it is flashing returns to the latest trend sampling display.  
At this point, the switch stops flashing and the cursor disappears.

6 Reset Press this switch once to turn on its lamp and then press it again within 
two seconds to clear the contents of the buffering area.  Sampling starts 
again immediately after the buffering area is cleared.
If the switch is not pressed again within two seconds, the switch’s lamp 
turns off and resetting is nullified.

7 Zoom In Zoom in on the graph display by 2, 4, and 8 times.
Each press doubles the magnification and halves the number of X-axis 
data points.

Actual size → 2 times → 4 times → 8 times

8 Zoom Out Zoom out of the magnified graph.
Each press halves the magnification and doubles the number of X-axis 
data points.

8 times → 4 times → 2 times → actual size

5 4 2 1 3 67 8



6. Trend Screen (Trend Sampling)

6-33

C
hecking O

peration on the U
nit

6

♦ Numerical Displays
The numerical displays used in trend sampling are shown below.

1 Sampling count display Cursor hidden: Displays the current number of samplings.
Cursor shown: Displays the current number of samplings of the data 

selected with the cursor.

2 Cursor point value display Displays the cursor point value when the cursor is displayed using the 
roll up, roll down, next block, or previous block switch.
When the cursor is hidden, the latest values of the trend lines are 
displayed instead.

3 Sampling time display Indicates the last sampling time or the sampling time of the selected 
message.

Display differs depending on the number of specified digits.
Less than 8 digits Hidden
From 8 digits up to 14 digits hour : minute : second
15 digits or more month - day, hour : minute : second

4 Sampling time display
(start point of display)

Displays the display start time/display end time of the displayed graph.

5 Sampling time display
(end point of display)

1 2 3

4 5
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7. Screen Data Transfer
This chapter explains how to transfer screen data to the TS Series unit and export screen data 
from the TS Series unit.

Transfer methods include USB transfer by connecting the TS Series unit and computer with a USB 
cable, Ethernet transfer, and storage transfer using USB memory.

For more information on storage transfer, refer to the “TS Series Hardware Specifications” and “V8 
Series Reference Manual.”

Screen Data Transfer.......................................................................................................... page 7-2
1. USB Transfer ............................................................................................................ page 7-2
2. Ethernet Transfer...................................................................................................... page 7-9

Simulator........................................................................................................................... page 7-18
1. Overview................................................................................................................. page 7-18
2. Operation................................................................................................................ page 7-18

 Emulator........................................................................................................................... page 7-22
1. Overview................................................................................................................. page 7-22
2. Operation................................................................................................................ page 7-23

USB-AUSB-miniB

TS
Computer

Transfer Method TS1100i / TS1070i TS1100 / TS1070

USB

Ethernet ×

External storage device

Contents
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1. USB Transfer

1.1 Installing the USB Driver

A USB driver must be installed to the computer in advance to perform USB transfer.  Install the 
driver according to the following procedure.

♦ For Windows Vista/7/8
1. Connect the USB-miniB port of the TS series (with power on) to the USB-A port of the 

computer using a USB cable.

2. The USB driver is automatically installed. During installation, the following message is 
displayed on the computer's taskbar.

3. The following message is displayed on the computer's taskbar when installation is finished.
When successfully completed, transfer the screen data. Refer to page 7-6.
If installation has terminated due to an error, reinstall the USB driver. See page 7-4.

- When successfully completed

- When terminated due to error

Screen Data Transfer

USB-AUSB-miniB

TS
Computer



7. Screen Data Transfer

7-3

S
creen D

ata Transfer

7

♦ For Windows XP
1. Connect the USB-miniB port of the TS series (with power on) to the USB-A port of the 

computer using a USB cable.

2. The message “Found New Hardware” and then the driver installation wizard appear on the 
computer.
Select [No, not this time] and click the [Next] button.

3. Select [Install the software automatically (Recommended)] on the [Hardware Update Wizard] 
and click [Next].

4. Installation of the USB driver starts.

USB-AUSB-miniB

TS
Computer
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5. Click the [Finish] button on the screen below.

♦ For OSs earlier than Windows XP
For more information, refer to the V8 Series Operation Manual.

♦ When USB driver installation fails
If automatic installation of the USB driver fails, perform installation by the following procedure.

1. Open the following folder from [My Computer] or [Windows Explorer].
- For Windows Vista/7/8

C:\MONITOUCH\V-SFT V5\INF
- For Windows XP

C:\Program Files\V-SFT V5\INF
2. Double-click "V-SFTV5_USBDriver.exe".

Depending on your computer, the following dialog may be displayed when using Windows 
Vista/7/8.
Click the [Yes] button.
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3. Click the [Next] button on the screen below.  Installation of the USB driver starts.

4. Click the [Finish] button on the screen below.

USB driver installation is complete.  Transfer the screen data.

♦ Recognition of USB Driver
When the driver has been installed successfully, the [Device Manager] window shows “Operation 
Panel - Operation Panel USB Driver”.

This will disappear when TS series and computer are disconnected.
If [Other Device] or a mark other than shown above is displayed even while the USB is connected, 
the USB driver is not recognized.  If this happens, uninstall the USB driver and reinstall it.

• For Windows Vista/7/8 • For Windows XP
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1.2 Transfer

1. Connect the USB-miniB port of the TS series to the USB-A port of the computer using a USB 
cable.

2. Click [File] → [Transfer] or click the [Transfer] icon.

3. Set [Transfer Device] to “Display” and [Transfer] to “Screen Data” in the [Transfer] dialog box.
Select the [ Use Simulator] checkbox to use the simulator.

USB-AUSB-miniB

TS
Computer

or

Simulator
If a PLC is not available during debugging, use the simulator to confirm screen operation with 
only the TS Series unit.  The simulator that runs on the computer acts as the PLC.
For more information, refer to page 7-18.

Emulator
If a TS Series unit is unavailable, use the emulator to confirm screen operation.
The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator 
acts as the PLC.  Refer to page 7-22.
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4. Check the [Communication Port] setting.
If the setting is “USB”, proceed to step 6.
If the setting is a serial port or Ethernet IP address, click the [Communication Setting] button 
and select “USB” under [Communication Port].

5. Click the relevant transfer button to start transferring screen data.

6. The following dialog box is displayed in the editor during transfer.

Transfer Method Description

PC→ Transfer screen data from the computer to the TS Series unit.

PC← Export screen data on the TS Series unit to the computer.

PC↔ Compare the data on the computer with the data on the TS Series unit.
Select the [  Text comparison] checkbox to obtain a more detailed 
comparison result.

• PC→ • PC← / PC↔
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The screen changes to the main screen and [Transferring Data] is displayed on the unit.
* If the main screen is not displayed and the transfer does not start, manually display 

the main screen and execute the transfer.

7. The [Transferring Data] display disappears when the transfer is complete.
• PC→

Start communication with the PLC.  Check unit operation.
• PC←

The exported data is displayed.  Save the data to a new file.
• PC↔

The comparison results are displayed.

When transferring to new units, the lamp flashes at the lower left of the five languages screen.
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2. Ethernet Transfer

2.1 IP Address Settings

The IP address of the unit must be configured in advance to allow Ethernet communication.

♦ Configuring New Units
1. The following screen is displayed after the power is turned on.

2. Press the [IP Address] switch.  The [Ethernet] screen is displayed.

3. Press the [EDIT] switch and configure each setting.
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4. Press the [Setting Finished] switch to confirm the IP address.  The screen returns to the five 
languages screen.

This completes IP address configuration.  Next, perform screen data transfer.



7. Screen Data Transfer

7-11

S
creen D

ata Transfer

7

♦ Configuring Existing Units
1. The PLC communication screen is displayed after the power is turned on.  If a PLC is not 

connected, the [Communication Error - Timeout] screen is displayed.
2. Press and hold your finger on any of the four screen corners (2 cm squares) for more than two 

seconds and then release your finger.

3. Next, press any of the remaining corners for more than two seconds within one second of 
releasing the first corner to display a system menu on the right side of the screen.

4. Press the [MODE] switch on the system menu.  The [Main Menu] screen is displayed.

2 cm

2 cm
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5. Press the [Main Menu] switch to display the menu.

6. Press the [Ethernet] switch to display the [Ethernet] screen.

The system menu cannot be displayed by holding down your finger on locations corresponding 
to switches, data displays with switches, display areas, slider switches, scroll bars, or table data 
displays.  Press a corner where these items are not located.

If items are located in all four corners, first change to a screen without items in the way before 
changing to the main screen.

Disabled due to 
switch
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7. Press the [EDIT] switch and configure each setting.

8. Press the [Setting Finished] switch to confirm the IP address and return to the [Main Menu] 
screen.
Check the IP address under [Ethernet Information].
If an error is displayed, recheck the cable and IP address.

This completes IP address configuration.  Next, perform screen data transfer.

The error is displayed next to the MAC address.

Example: ERR:801
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Executing the “ping” command on the computer is convenient way to check for problems with Ethernet 
connections.

Checking Using the Ping Command
Example: Check the connection state from the computer when the IP address of the unit is “172.16.200.150”.

Open a [Command Prompt] window on the computer.

Enter “ping  172.16.200.150” on the command line using the keyboard and press the [Enter] key.

The following result is displayed if the unit is connected.

The following result is displayed if the unit is disconnected.

Check the IP address of the unit and computer as well as the connection cable.

Connection 
OK

Disconnected
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2.2 Transferring Screen Data

1. Connect the LAN port on the unit to the computer using a LAN cable.

2. Click [File] → [Transfer] or click the [Transfer] icon.

3. Set [Transfer Device] to “Display” and [Transfer] to “Screen Data” in the [Transfer] dialog box.
Select the [ Use Simulator] checkbox to use the simulator.

Ethernet
PLCTSi

Computer

or

Simulator
If a PLC is not available during debugging, use the simulator to confirm screen operation with 
only the TS Series unit.  The simulator that runs on the computer acts as the PLC.  Refer to 
page 7-18.

Emulator
If a TS Series unit is unavailable, use the emulator to confirm screen operation.
The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator 
acts as the PLC.  Refer to page 7-22.
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4. Check the [Communication Port] setting.
If the setting is Ethernet and the IP address is correct, proceed to step 6.
If the setting is a serial port or USB, click the [Communication Setting] button and select 
“Ethernet” under [Communication Port].

5. Click the relevant transfer button to start transferring screen data.

6. The following dialog box is displayed in the editor during transfer.

Transfer Method Description

PC→ Transfer screen data from the computer to the TS Series unit.

PC← Export screen data on the TS Series unit to the computer.

PC↔ Compare the data on the computer with the data on the TS Series unit.
Select the [  Text comparison] checkbox to obtain a more detailed 
comparison result.

• PC→ • PC← / PC↔
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The screen changes to the Main Menu screen and [Transferring Data] is displayed on the unit.

7. The [Transferring Data] display disappears when the transfer is complete.
• PC→

Start communication with the PLC.  Check unit operation.
• PC←

The exported data is displayed.  Save the data to a new file.
• PC↔

The comparison results are displayed.

When transferring to new units, the lamp flashes at the lower left of the five languages screen.
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1. Overview

If a PLC is not available during debugging, use the simulator to confirm screen operation with only 
the TS Series unit.  The simulator that runs on the computer acts as the PLC.

* The simulator can be used for 1:1 connections between the TS Series unit and a connected 
device.
The simulator cannot be used for 1:n and n:1 connections.

* The simulator cannot be used when the connection device is a barcode reader or slave 
communication device (V-Link, MODBUS slave).

2. Operation

2.1 Configuring the TS Series Unit
When using the simulator, always configure the unit to [Simulator] instead of [Real machine] (other 
devices) on the unit itself.

1. Press the [Main Menu] switch to display the menu.

2. Press the [Simulator] switch to display the [Simulator] screen.

Simulator

Switches and Lamps
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3. Configure the settings for [Setting at connection destination] and [Simulation Driver Setting].
• USB connection

Select [Simulation] under [Simulation Driver Setting] and press [Setting Finished].

• Ethernet connection
Set the IP address of the computer under [Setting at connection destination].  Do not 
change the port number.
Select [Simulation] under [Simulation Driver Setting] and press [Setting Finished].

If the [Simulator] switch does not appear on the menu, the simulator program has not been 
transferred to the unit.
In this case, select the [  Use Simulator] checkbox in the [Transfer] dialog box and transfer the 
screen data again.
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4. Press the [Main Menu] switch to display the menu.

5. Press the [RUN] switch to display the [RUN] screen.
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2.2 Simulator

1. Click [View] → [View] → [Simulate] or click the [Simulate] icon.

2. The simulator starts and the relevant screen is displayed on the TS Series unit.

3. Confirm screen operation on the TS Series unit.  In addition, changing values on the simulator 
updates the display on the unit.
For more information on simulator operation, refer to the “V8 Series Operation Manual.”

or
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1. Overview

If a TS Series unit is unavailable, use the emulator to confirm screen operation.
The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator acts 
as the PLC.

Emulator

Shows a representation of unit screen display on the computerEmulator

Simulator Implements memory operations instead of the PLC
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2. Operation

1. Click [File] → [Start Emulator].

2. The simulator and TELLUS emulator start automatically.

3. The same operations of pressing switches on the unit can be performed by clicking switches 
on the emulator.  In addition, changing values on the simulator updates the display on the 
emulator.
For more information on simulator operation, refer to the “V8 Series Operation Manual.”
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